ECS : Mise à niveau du code PFE pour baie All-Flash (AFA) Gen 3 Plate-forme EXF900 - ET-5187

Summary: Cet article de la base de connaissances (KB) documente Proactive Field Event (PFE) ET-5187 pour les mises à niveau de code ECS Gen3 EXF900. PFE est le nouveau terme utilisé pour désigner les programmes FCO (Field Change Order). ...

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Symptoms

Les systèmes de baies All-Flash EXF900 Gen 3 peuvent rencontrer les problèmes suivants :

  • Les problèmes de performances ont affecté les opérations de lecture et d’écriture. 
  • Instabilité d’ECS due à des tables de répertoire (DT) non prêtes, ce qui peut entraîner une indisponibilité des données (DU). 

Cause

  • Pour les problèmes de performances : Reportez-vous aux Notes de mise à jour d’ECS 3.8.1.4 pour obtenir la liste des problèmes résolus susceptibles d’avoir un impact sur les performances d’ECS. 
  • Pour les DT non prêts, cela peut être dû à une condition de concurrence entre les services ECS, ce qui peut entraîner un vidage de métadonnées incohérent entre les services.

Resolution

  • Les responsables de l’ingénierie, de la qualité et des services ECS demandent un événement proactif sur le terrain (PFE) pour tous les systèmes All-Flash Array Gen 3 EXF900. 
  • Le PFE consiste à effectuer une mise à niveau vers le code recommandé le plus récent ECS 3.8.1.5 General Availability (GA), qui contient un correctif pour les problèmes décrits dans cet article de la base de connaissances. 
    • Pour plus d’informations sur le code cible et recommandé ECS, consultez les articles de la base de connaissances 216334 et 205512.
  • Dell Technologies ouvrira des demandes de service de mise à niveau dans le cadre du PFE. 
  • Une fois la mise à niveau terminée, les services Dell lancent une analyse pour détecter les éventuelles incohérences de vidage des métadonnées qui auraient pu se produire lors de l’exécution de niveaux de code antérieurs par ECS.
    • Si vous êtes connecté à l’aide de Secure Connect Gateway (SCG) ou si vous avez activé Call Home sur un serveur SMTP (Simple Mail Transfer Protocol) dédié, une demande de service est créée si le scanner détecte des métadonnées affectées ou rencontre un problème d’exécution. Aucune surveillance n’est nécessaire. 
    • Si votre boîtier ECS n’émet pas d’appel à distance, vous devez surveiller les résultats de l’analyse. Pour obtenir des instructions, reportez-vous à la section Informations supplémentaires de cet article de la base de connaissances. 

Additional Information

Vérifiez les résultats de l’analyse après la mise à niveau vers ECS 3.8.1.4 ou versions supérieures.

  1. Connectez-vous à l’hôte ECS à l’aide de SSH :
# ssh ecs.host.com
  1. Connectez-vous au nœud principal :
# ssh master
  1. Exécutez la vérification :
# sudo python /usr/local/xdoctor/tools/scanners/btree_invalid_page_scan.py status 

Exemple :

admin@murray-EX500:~> ssh master
Last login: Thu Aug 26 20:42:02 2021 from 10.184.65.213

admin@murray-EX500:~> sudo python /usr/local/xdoctor/tools/scanners/btree_invalid_page_scan.py status
btree_invalid_page_scan.py v1.2.0 (svc_tools v2.21.0)                 Started 2025-01-16 18:50:05

Start                Resume   Last Update                    Complete  ETA
Node    JobID                                          Time                 Time     Time                 Progress  DT        Hours   Status    SubStatus  Conclusion
----------------------------------------------------------------------------------------------------------------------------------------------------------------------
r01n01  DTABtreeInvalidPageScanner-3-1737053178-50097  2025-01-16 18:46:18  Unknown  2025-01-16 18:46:58  100.00 %  128/128   0.00    Complete             NotImpacted

 

Si l’analyse signale que le VDC est affecté :

  • Une demande de service est requise pour enquêter.
    • Pour les clients disposant de sites connectés, vérifiez qu’une demande de service a été créée. 
    • Clients Dark Site, contactez le support Dell pour ouvrir une demande de service.
  • Il est possible qu’un impact soit identifié avant que l’état de l’analyse soit terminé. Contactez le support Dell si vous voyez Impacted.
 

Aucune action supplémentaire n’est requise si l’analyse signale que le disque virtuel n’est pas affecté et n’est pas affecté.

Affected Products

ECS, ECS Appliance, ECS Appliance Hardware Series, ECS Appliance Software with Encryption, ECS Appliance Software without Encryption
Article Properties
Article Number: 000252800
Article Type: Solution
Last Modified: 02 Dec 2025
Version:  6
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