ECS: Code Upgrade PFE for All-Flash Array (AFA) Gen3 EXF900 Platform - ET-5187

Summary: This Knowledge Base (KB) article documents Proactive Field Event (PFE) ET-5187 for ECS Gen3 EXF900 code upgrades. PFE is the new term for Field Change Order (FCO) programs.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Gen3 EXF900 All-Flash Arrays systems may experience:

  • Performance issues impacted read and write operations. 
  • ECS instability due to unready Directory Tables (DTs), which may lead to data unavailability (DU). 

Cause

  • For the performance issues: Refer to the ECS 3.8.1.4 Release Notes for a list of fixed issues that would impact ECS performance. 
  • For the unready DTs, this may be caused by a race condition between ECS services, which may lead to due to inconsistent metadata dump between the services.

Resolution

  • ECS Engineering, Quality, and Services leadership are requesting a Proactive Field Event (PFE) for all All-Flash Array Gen3 EXF900 systems. 
  • The PFE is to upgrade to the latest Recommended Code ECS 3.8.1.5 General Availability (GA), which contains a fix to the issues described in this KB article. 
    • For more information about ECS Target and Recommended Code, check KB articles 216334 and 205512.
  • Dell Technologies will open Upgrade Service Requests as part of the PFE. 
  • Once the upgrade is complete, Dell Services initiates a scan to detect potential metadata dump inconsistencies which might have occurred when ECS ran earlier code levels.
    • If you are connected using Secure Connect Gateway (SCG) or have call-home enabled over a dedicated Simple Mail Transfer Protocol (SMTP) server, then a Service Request would be created if the scanner finds impacted metadata or runs into a run-time issue. No monitoring is needed. 
    • If your ECS box is not calling home, then you must monitor the scan results. See the Additional Info section of this KB article for the instructions. 

Additional Information

Check scan results after upgrading to ECS 3.8.1.4 or later versions.

  1. Connect to an ECS host using SSH:
# ssh ecs.host.com
  1. Connect to the principal node:
# ssh master
  1. Run the check:
# sudo python /usr/local/xdoctor/tools/scanners/btree_invalid_page_scan.py status 

Example:

admin@murray-EX500:~> ssh master
Last login: Thu Aug 26 20:42:02 2021 from 10.184.65.213

admin@murray-EX500:~> sudo python /usr/local/xdoctor/tools/scanners/btree_invalid_page_scan.py status
btree_invalid_page_scan.py v1.2.0 (svc_tools v2.21.0)                 Started 2025-01-16 18:50:05

Start                Resume   Last Update                    Complete  ETA
Node    JobID                                          Time                 Time     Time                 Progress  DT        Hours   Status    SubStatus  Conclusion
----------------------------------------------------------------------------------------------------------------------------------------------------------------------
r01n01  DTABtreeInvalidPageScanner-3-1737053178-50097  2025-01-16 18:46:18  Unknown  2025-01-16 18:46:58  100.00 %  128/128   0.00    Complete             NotImpacted

 

If the scan reports that the VDC is impacted:

  • A Service Request is required to investigate.
    • Customers with Connected Sites, verify that a Service Request is created. 
    • Dark Site customers, contact Dell support to open a Service Request.
  • It is possible that an impact is identified before the scan status is Complete. Contact Dell Support if you see Impacted.
 

No additional action is required if the scan reports that the virtual disk is not impacted NotImpacted.

Affected Products

ECS, ECS Appliance, ECS Appliance Hardware Series, ECS Appliance Software with Encryption, ECS Appliance Software without Encryption
Article Properties
Article Number: 000252800
Article Type: Solution
Last Modified: 02 Dec 2025
Version:  6
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