Isilon: Kan ikke finne diskleverandørfeil ved reimageg
Summary: Kan ikke finne diskleverandørfeil kan oppstå når reimage-programmet ikke finner en bootstrap-leverandør.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Feilmeldingen "Finner ikke diskleverandør" vises under reimageprosessen.
Cannot find disk provider
Traceback (most recent call last):
File "/root/bin/flashdisk_reimage.py", line 2375, in
sys.exit(main(getargs()))
File "/root/bin/flashdisk_reimage.py", line 2251, in main
setup_psi(args)
File "/root/bin/flashdisk_reimage.py", line 1703, in setup_psi
setup_psi_backup_device(args)
File "/root/bin/flashdisk_reimage.py", line 1763, in setup_psi_backup_device
psi_backup_device.providers.init_short()
File "/root/bin/flashdisk_reimage.py", line 1213, in init_short
bootdisk.init_providers(wipe=False)
File "/b/mnt/obj/b/mnt/src/amd64.amd64/isilon/lib/python/stage-3.8/usr/local/lib/python3.8/site-packages/isi/sys/bootdisk.py", line 729, in init_providers
File "/b/mnt/obj/b/mnt/src/amd64.amd64/isilon/lib/python/stage-3.8/usr/local/lib/python3.8/site-packages/isi/sys/bootdisk.py", line 730, in
IndexError: list index out of range
Kommandoen for å bekrefte problemet er: isi_bootstrap_devices -b, som gir følgende utdata:
isi-bsd# /usr/bin/isi_hwtools/isi_bootstrap_devices -b name: isi-bsd#
Cause
Årsaken til dette problemet er at disken mangler i det høyeste spornummeret for A-sleden for noden.
Resolution
Hvis du vil løse problemet, gjør du følgende:
- Sett en stasjon inn i det høyeste spornummeret på A-sleden for noden. Hvis disken ble fjernet på grunn av en feil, må du skifte ut den defekte disken før du fortsetter.
- Hvis du har en stasjon i det høyeste A-spornummeret, bytter du ut stasjonen med en annen stasjon i sleden. Når sleden er satt inn igjen, kan du prøve å utføre reimageprosessen på nytt.
Forsiktig: Hvis du er usikker eller bekymret for å gjøre disse endringene, kan du kontakte Dells kundestøtte eller sjekke nettstedet deres for å få mer hjelp.
Merk: Hog les maskinvaren forsiktig for å unngå skade.
Affected Products
Isilon Gen6, PowerScale A310, PowerScale A3100, PowerScale H710, PowerScale H7100Article Properties
Article Number: 000359362
Article Type: Solution
Last Modified: 17 Oct 2025
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.