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Dell EMC Unity: ViPR user receives 500 error on login to the array through REST call (Dell EMC Correctable)

Summary: Apply temporary timer edit to the cas-servlet.xml file after an upgrade.

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Symptoms

 

ViPR logins to the array that utilize REST and an LDAP user may result in an html 500 code being returned.

This can be seen in the apache access_log (/nas/http/logs/access_log):
192.168.1.56 - - [31/Jan/2019 17:47:10.822820] 2469421 [31/Jan/2019 17:47:13.292241] "GET /cas/login;JSESSIONID=7CE46607BF48A30429EC6553EF94C785?username=<username>%40<domain>&password=<password>&lt=LT-6519-gefNjJzSYRVfy1UuzSAwieHjBr9FCw-Unisphere&execution=e1s1&_eventId=submit HTTP/1.1" 500 1018 "-" "Apache-HttpClient/4.5.2 (Java/1.8.0_162)"
192.168.1.56 - - [31/Jan/2019 17:47:11.240570] 2871122 [31/Jan/2019 17:47:14.111692] "GET /cas/login;JSESSIONID=A2DA2D5AD53338F9AFA0EF6B6EB3CC36?<username>%40<domain>&password=<password>&lt=LT-6520-eckw75hW7d1xzAe7HdRYG6VDIGbuO5-Unisphere&execution=e1s1&_eventId=submit HTTP/1.1" 500 1018 "-" "Apache-HttpClient/4.5.2 (Java/1.8.0_162)"


Any 500 status returned should be investigated on the Unity array as that denotes a server side error.  Statuses in the 400 range are considered client side errors and should be investigated on the client sending the call to the array.

Cause

In this particular case, there is a slight delay in the LDAP bind response which was within the array's default value of 5 seconds, but caused CAS (central authentication service) logins to fail due to a separate default 2 second timeout value in CAS's web session listener.

Resolution

This issue has been fixed in Unity code 5.0.0.0.5.116 and above.  If you are on an earlier version of code, please upgrade to 5.0.0.0.5.116 or a more recent code to resolve this issue.



Additional Information

This content is translated in other languages: 
https://downloads.dell.com/TranslatedPDF/PT-BR_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/AR-EG_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/DE_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/ES_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/FR_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/KO_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/JA_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/IT_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/NL_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/PT_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/RU_KB530019.pdf
https://downloads.dell.com/TranslatedPDF/SV_KB530019.pdf

Affected Products

Dell EMC Unity Family

Products

Dell EMC Unity Family