PowerStore: What to expect while VASA provider is down?

Summary: With VMware vSphere, vVol architecture utilizes a control plane and a data plane between the Storage environment and the vSphere environment. They communicate using vStorage APIs for Storage Awareness (VASA). Some PowerStore storage operations, such as software upgrades, lock the VASA Provider and temporarily pause VASA commands in the control plane while the storage operation is running. ...

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Symptoms

When the PowerStore VASA Provider is paused, the vSphere UI can list either local (PowerStore-X) VVol datastores as inaccessible, or hosted VVol datastores (PowerStore-T or PowerStore-X) as inaccessible.  This is observed when the vSphere to PowerStore VASA control plane communication is paused.  The vSphere UI VASA information is stale and is presented as (inaccessible).

Any vVols using the VASA provider will not be accessible in the UI. Data is using the unaffected data plane.  This can be concerning but should not be acted upon without confirmation of an actual problem.
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Note: When the PowerStore VASA provider is in the described state, some vSphere operations are restricted:

  • VM Creation
  • Clone a VM
  • Power on a VM.
  • Power off a VM.
  • Shut down a VM.
  • Storage vMotion to another SC on the same PowerStore
  • Compute vMotion
  • Delete a VM.
  • Create a Snapshot
For some customers, the vSphere UI inaccessible status or the inability to perform such VM operations may be considered disruptive.

Some operations may fail with a vCenter errors similar to: Module MonitorLoop power on failed. Failed to start the virtual machine.

Other operations may also not be supported while the VASA provider is inaccessible or offline, including in-guest limitations.

Cause

The VASA provider can be inaccessible or offline for various causes, such as network, vCenter, and/or PowerStore issues or during storage operations such as code upgrade. This doesn’t mean that the data is unavailable, IO can still be served and VMs are still running.

Resolution

With PowerStore OS version 3.0 (or later versions), VASA downtime was minimized by improving and lowering failover & startup times.

When experiencing this, DO NOT try to reboot ESXi hosts or PowerStore nodes.

How to check VASA status?

Using the vSphere UI

Navigate to the vCenter Server > Configure > Storage Providers and locate the PowerStore VASA Provider.

  • The status should be online

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Using the ESXi Command Line

  • Ssh to the ESXi host
  • Run the command: esxcli storage vvol vasaprovider list
  • Status should be Online

image-2022-09-22-11-50-04-228.png

When to reach out PowerStore Global Support?

  • If there is a data plane disruption to a vVol-based VM
  • The VASA control plane does not auto-recover after a period of time.
    • This varies depending on usage from 5-10 minutes to 30-60+ minutes for an environment with thousands of vVols.

Additional Information

Affected Products

PowerStore
Article Properties
Article Number: 000205326
Article Type: Solution
Last Modified: 08 Sept 2025
Version:  4
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