Avamar: rendimiento de respaldo deficiente para el cliente Avamar que ejecuta el antivirus Celerra
Summary: En este artículo, se analizan situaciones en las que un cliente Avamar que ejecuta el antivirus Celerra experimenta un rendimiento deficiente del respaldo.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Este comportamiento puede causar respaldos de Avamar de larga ejecución y puede impedir que los respaldos finalicen dentro de la ventana de respaldo disponible.
En ocasiones, un cliente Avamar en el que está instalado el antivirus Celerra puede experimentar un rendimiento de respaldo deficiente cuando se ejecuta un análisis de Celerra según demanda en el sistema.
En los días en que el antivirus de Celerra ejecuta un análisis según demanda, Avamar puede informar que la proporción de archivos modificados es alta.
En otros días, la proporción de archivos modificados es más típica.
En ocasiones, un cliente Avamar en el que está instalado el antivirus Celerra puede experimentar un rendimiento de respaldo deficiente cuando se ejecuta un análisis de Celerra según demanda en el sistema.
En los días en que el antivirus de Celerra ejecuta un análisis según demanda, Avamar puede informar que la proporción de archivos modificados es alta.
avtar Info <5156>: Backup #82 timestamp 2014-03-21 16:24:53, 80,687 files, 11,757 folders, 46.06 GB (80,188 files, 17.03 GB, 36.98% new) avtar Info <6083>: Backed-up 46.06 GB in 73.38 minutes: 38 GB/hour (65,976 files/hour)Aquí, avtar informa que los datos modificados (los valores entre corchetes) son muy altos en relación con el conjunto de datos que se respalda. En este caso, se detecta que más del 99 % de los archivos ha cambiado (80 188 archivos de 80 687)
En otros días, la proporción de archivos modificados es más típica.
avtar Info <5156>: Backup #91 timestamp 2014-04-03 10:11:54, 139,164 files, 13,805 folders, 60.73 GB (4 files, 280.1 KB, 0.00% new) avtar Info <6083>: Backed-up 60.73 GB in 7.03 minutes: 519 GB/hour (1,188,522 files/hour)
Cause
El proceso del cliente Avamar (avtar) depende del ctime de un archivo para determinar si se cambió ese archivo. Si el software de otros fabricantes altera el ctime de un archivo en el conjunto de datos, avtar detectará que ese archivo cambió. A continuación, Avtar debe procesar (fragmento, comprimir, hash) todo el archivo.
Esto puede tardar mucho tiempo si muchos archivos han modificado su ctime o si los archivos individuales son grandes.
Como se explica en la documentación
de Sophos 7.4, Archiver respalda todos los archivos que se escanearon según demanda.
Esto se debe a los cambios que El antivirus Celerra realiza en la hora de los archivos con cambios de estado. De manera predeterminada, Celerra Anti-Virus intenta restablecer la hora de acceso (atime) de los archivos a la hora que se muestra antes del escaneo.
Sin embargo, esto cambia la hora de cambio del estado del inodo (ctime). Si el archiver utiliza ctime para decidir si un archivo ha cambiado, respalda todos los archivos escaneados por El antivirus Celerra.
Resuelva el problema:
Ejecute un barrido con la opción--no-reset-atime.
Esto puede tardar mucho tiempo si muchos archivos han modificado su ctime o si los archivos individuales son grandes.
Como se explica en la documentación
de Sophos 7.4, Archiver respalda todos los archivos que se escanearon según demanda.
Esto se debe a los cambios que El antivirus Celerra realiza en la hora de los archivos con cambios de estado. De manera predeterminada, Celerra Anti-Virus intenta restablecer la hora de acceso (atime) de los archivos a la hora que se muestra antes del escaneo.
Sin embargo, esto cambia la hora de cambio del estado del inodo (ctime). Si el archiver utiliza ctime para decidir si un archivo ha cambiado, respalda todos los archivos escaneados por El antivirus Celerra.
Resuelva el problema:
Ejecute un barrido con la opción--no-reset-atime.
Resolution
Siga la documentación de Sophos y configure Sophos para que se ejecute con la opción --no-reset-atime.
Affected Products
AvamarProducts
Avamar, Avamar ClientArticle Properties
Article Number: 000041039
Article Type: Solution
Last Modified: 06 Feb 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.