AvamarとCIFS(SMB)およびNFSにマップされたネットワーク共有のサポート

Summary: この記事では、通常のAvamarクライアントが、CIFS(SMB)およびNFSにマップされたネットワーク共有からのデータのバックアップを正式にサポートしていないことを説明します。NDMPアクセラレーター ノードのみがこの機能をサポートしています。 特殊な状況に対する回避策はありますが、サポートは限られています。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

通常のAvamar Clientは、マップされたCIFSドライブおよびエクスポートされたNFSマウントからデータをバックアップできますが、この機能は正式にはサポートされていません。

Dellサポートは、このようなデータのバックアップまたはリストアに関連する問題の構成やトラブルシューティングを支援しません。

CIFS、NFS、SMB共有のバックアップに関連する一般的な問題には、次のようなものがありますが、これら に限定されません
  • UNIX Avamar Clientを使用してWindowsデータをバックアップすると、WindowsのACL(アクセス制御リスト)が失われます。逆に、Windowsクライアントを使用してUNIXデータをバックアップした場合、UNIX ACLは失われます。
  • バックアップ パフォーマンスが低下する可能性があります。
  • お客様にサード パーティーの問題が発生する可能性があります。
  • CIFSバージョンの相互運用性が原因で問題が発生する可能性があります。
  • マッピングされたCIFSまたはNFS共有全体にあるデータのVSSのようなスナップショットを実行する機能はありません。開いているファイルのバックアップに一貫性がない可能性があります。



Cause

この機能は公式にはサポートされていません。

バックアップ クライアント ユーザー ガイドからの抜粋:
「ローカル マシンにAvamarクライアントをインストールして、CIFS/NFSネットワーク共有をバックアップしないでください。これを行おうとすると、バックアップとリストアのパフォーマンスが著しく低下し、フォルダー、ACL、ファイル権限などのメタデータがバックアップされません。CIFS/NFS共有をバックアップするには、共有マシンにAvamarクライアントをインストールするか、NDMPを使用してデータをバックアップします。」

Resolution

NASファイラーなどのストレージ デバイスは、Avamarネットワーク データ管理プロトコル(NDMP)アクセラレーターを使用してバックアップする必要があります。

Avamar NDMPアクセラレーター ノードは、専用のAvamarクライアントです。通常のAvamar Linuxクライアント ソフトウェアとAvamar NDMPプラグインを実行し、NDMPプロトコルを使用して、サポートされているファイラーからデータをバックアップします。
NDMPアクセラレーター機能の詳細については、Avamar NDMPアクセラレーター ガイドを参照するか、EMCアカウント マネージャーにお問い合わせください。

CIFSまたはNFSを使用してデータをエクスポートするシステムに、Avamarがサポートするオペレーティング システムがある場合は、クライアントをインストールしてファイルを直接収集します。
可能な場合は、CIFS、NFS、またはSMB共有をホストしているサーバーを、ファイル システムにインストールされているクライアントで直接バックアップする必要があります。

回避策:

手順1:
お客様は、サポートが制限されていることを受け入れ、完全に理解し、次の条件に同意することに同意し、Eメールで応答する必要があります。

お客様は、以下の制限事項を読み、完全に理解していること。

CIFS、NFS、SMB共有のバックアップに関連する一般的な問題には、次のようなものがありますが、これら に限定されません
  • UNIX Avamar Clientを使用してWindowsデータをバックアップすると、WindowsのACL(アクセス制御リスト)が失われます。逆に、Windowsクライアントを使用してUNIXデータをバックアップした場合、UNIX ACLは失われます。
  • バックアップ パフォーマンスが低下する可能性があります。
  • お客様にサード パーティーの問題が発生する可能性があります。
  • CIFSバージョンの相互運用性が原因で問題が発生する可能性があります。
  • マッピングされたCIFSまたはNFS共有全体にあるデータのVSSのようなスナップショットを実行する機能はありません。開いているファイルのバックアップに一貫性がない可能性があります。
  • サポートは限定的であり、ベスト エフォートとして提供されます。
続行する前に、Eメールがケースに表示されることを確認します。

手順2:
お客様は、共有のソースに対して完全な管理者(ドメイン管理者)権限を持つアカウントを選択または作成する必要があります。

ステップ3:
バックアップの実行に使用するクライアントで、ステップ2でアカウントとしてログインするように「バックアップエージェント」サービスを設定します。

ステップ4:
バックアップの場合は、特定のデータセットを定義し、UNC形式を使用して共有のパスを指定します。
プラグイン オプションの[ソース データ]タブで、[
すべてのローカルWindowsファイル システムを含めない]を選択するか、[すべてのローカルWindowsファイル システム]を選択します。デフォルトでは、[All local Windows file system]が選択されています。これにより、すべてのファイル システム データがバックアップされます。
お客様は、データセットを特定の項目に限定し、次の手順
を実行する必要があります。ファイルまたはフォルダーのパスに、例としてパスを入力します。\\server\share\フォルダー
b[ADD]をクリックします。

リストアの場合、宛先フォルダーを例として指定する必要があります。\\server\share\フォルダー

Additional Information

Common Internet File System(CIFS)SMB(Server Message Block)

Network File System(NFS)
Network Data Management Protocol(NDMP)UNC
(Universal Naming Convention)RPQ(Request for Product Qualification)

NAS(ネットワーク接続型ストレージ)

Affected Products

Avamar, Avamar Client

Products

Avamar, Avamar Client, Avamar Client for Windows, Avamar Plug-in for NDMP
Article Properties
Article Number: 000046220
Article Type: Solution
Last Modified: 11 Apr 2024
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.