Avamar: Avamar Server 시간 이동으로 인해 MSG_ERR_ROLLING_CHECK HFSCHECK가 실패함

Summary: 시간 소스가 잘못되면 Avamar 체크포인트 검증(hfscheck)이 실패합니다.

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Symptoms

주요 증상:

 

유지 보수 작업(체크포인트 및 hfscheck)가 성공적으로 완료되지 않았습니다.

체크포인트 검증(hfscheck)가 MSG_ERR_ROLLING_CHECK에서 실패합니다.

최신 체크포인트가 이미 검증되었으므로 다시 검증할 수 없습니다.

cplist 명령은 미래 날짜 및 시간과 함께 체크포인트를 표시합니다.

cplist
cp.20201103213238 Wed Nov  3 16:32:38 2020   valid --- del  nodes   1/1 stripes   4779
cp.20201104153925 Thu Nov  4 10:39:25 2020   valid --- ---  nodes   1/1 stripes   4796
cp.20320218180432 Wed Feb 18 12:04:32 2032   valid rol ---  nodes   1/1 stripes   4521
 

체크포인트의 수동 유효성 검사 시도가 실패합니다.

avmaint hfscheck --checkpoint=cp.20201104153925 --rolling
ERROR: avmaint: hfscheck: server_exception(MSG_ERR_ROLLING_CHECK)
 
 
보조 증상:

유지 보수 오류 외에도 나중에 백업이 나열되는 2차 문제가 발생할 수 있으며, 그 결과 다음과 같은 문제가 발생할 수 있습니다.
  • 예측 및 보고서가 정확하지 않습니다.
  • MCS(Management Console Server) UI 정보가 올바르지 않을 수 있습니다.
  • 특정 보고서(예: 'Completed Activities - Failed' 및 'Activity Report')가 올바르지 않습니다.
 

2019년에 실행되었지만 2032년을 보고하는 백업의 샘플 출력:

mccli backup show --name=/clients/client_name
0,23000,CLI command completed successfully.

Created                       LabelNum Size        Retention
----------------------------- -------- ----------- ---------
2032-02-17 19:01:41 GMT-06:00 15       23875106816 DMY
 

-- 또는 MCS 플러시: --

avtar --backups --id=MCUser --ap=<password> --path=/MC_BACKUPS --hfsaddr=<server>--count=26
Date       Time     Seq    Label   Size    Plugin   Working directory    Targets
---------- -------- ------ ------- ------- -------- -------------------- -------------------------
2032-02-15 09:01:05 8373           116436K Linux    /usr/local/avamar    var/mc/server_data/

Cause

시간 서버 문제로 인해 Avamar 그리드의 시계가 2032년으로 재설정되었습니다.

이 기간 동안 체크포인트 검증이 수행되었으며 현재 2032년부터 검증된 cp가 있습니다.

엔지니어링 팀은 이것이 잘못된 시간 소스를 사용할 때 예상되는 동작임을 확인했습니다.

참고: 이 문제는 미래의 어느 날짜에나 발생할 수 있습니다.

Resolution

주의 사항:

백업 시간에 차이가 있는 경우(위의 2차 증상에 따라) 이를 먼저 수정해야 합니다. 이 문서의 단계를 수행하지 말고 대신 Dell Technologies 기술 지원 부서에 문의하여 추가 지원을 받으십시오.
 

해결하려면 hfscheck 문제:

1. 스케줄러를 재설정합니다.

avmaint sched reset --ava 
 

2. 스케줄러를 중지하고 시작합니다.

avmaint sched stop --ava
avmaint sched start --ava
 

3. 체크포인트를 지정합니다.

4. 수행 hfscheck.

5. 다음 예약된 유지 보수 기간 동안 그리드를 모니터링하여 문제가 해결되었는지 확인합니다.

 

 

Affected Products

Avamar

Products

Avamar, Avamar Server
Article Properties
Article Number: 000163146
Article Type: Solution
Last Modified: 23 Apr 2025
Version:  8
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