OpenManage Enterprise: Wichtiger Hinweis zum Fehler beim Upgrade auf 4.4.0
Summary: Es wurde ein Problem identifiziert, bei dem nach dem Upgrade auf OpenManage Enterprise 4.4.0 nicht mehr auf die Web-Benutzeroberfläche (UI) zugegriffen werden kann. Die Webnutzeroberfläche scheint bei "Pakete werden installiert" oder "Lädt... Services werden gestartet" oder "Einige oder alle Services sind inaktiv". Das Überwachen des Betriebssystemstarts über die virtuelle Konsole zeigt, dass der Docker Application Container Engine-Service nicht gestartet werden kann. ...
Symptoms
Nach Abschluss des Updates auf Version 4.4.0 startet die Appliance neu, um die aktualisierten Pakete zu initialisieren und zu aktivieren. Unter normalen Umständen lädt die Textnutzeroberfläche (TUI) die Core-Services beim Start und die Aufgabe nach dem Upgrade schließt das Upgrade ab.
In einigen Fällen wird jedoch festgestellt, dass der Docker Application Container Engine-Service nach dem ersten Neustart nicht gestartet werden kann. In diesen Fällen wird Folgendes angezeigt:
Die Webnutzeroberfläche bleibt mit der Meldung "Paket wird installiert..." hängen. für mehrere Stunden.

Die Web-Benutzeroberfläche blieb mit der Meldung "Loading... Die Dienste laufen." für mehrere Stunden.

Die virtuelle Konsole der Appliance zeigt an, dass der Docker-Service nicht gestartet werden kann.

Die Textnutzeroberfläche (TUI) wird geladen, nachdem die Timeouts für den Servicestart überschritten wurden. Die Weboberfläche zeigt jedoch an, dass einige oder alle Dienste inaktiv sind, und das Statusfenster der TUI Appliance weist mehrere Dienste als "inaktiv" an.

Wenn Sie die TUI starten und "Aktuellen Appliance-Status anzeigen" und dann "Fortfahren" auswählen, werden die meisten Dienste als inaktiv angezeigt.

Cause
OpenManage Enterprise nutzt Docker zur Virtualisierung (Containerisierung) mehrerer Kernanwendungen. Docker verwendet eine interne Schnittstelle, um die Netzwerkkommunikation für diese containerbasierten Anwendungen zu ermöglichen. Während der Initialisierung wird die Docker-Schnittstelle in eine dedizierte Firewallzone verschoben, um diesen Datenverkehr von der primären Schnittstelle zu isolieren.
Nach Abschluss eines vorherigen Upgrades auf Version 4.2.x oder 4.3.x wird die Docker-Schnittstelle jedoch aus der dedizierten Zone verschoben. Dies verhindert die Netzwerkkommunikation und beeinträchtigt den Start des Dienstes bei der nächsten Aktualisierung des Dienstes.
Wenn zwischen der vorherigen und der aktuellen Ausführung des Updates kein Neustart der Appliance ausgelöst wird, kann der Docker-Service nicht gestartet werden und die Appliance ist nicht zugänglich.
Resolution
Ab dem 01. Mai 2025 wurde das Upgrade auf Version 4.4.0 aus dem Online-Updatekatalog von OpenManage Enterprise entfernt. Die Upgradeversion 4.4.1, die am 23. Mai 2025 veröffentlicht wurde, enthält die Korrektur der Docker-Schnittstelle. Neue Bereitstellungen der OpenManage Enterprise Version 4.4.0 Appliance sind nicht betroffen und können weiterhin auf www.dell.com heruntergeladen werden. Wenn Sie das Upgrade auf Version 4.4.0 erfolgreich durchgeführt haben, sind keine weiteren Maßnahmen erforderlich.