OpenManage Enterprise: Viktigt meddelande om fel vid uppgradering av 4.4.0

Summary: Ett problem som innebär att webbanvändargränssnittet (UI) inte längre är tillgängligt efter uppgradering till OpenManage Enterprise 4.4.0. Webbgränssnittet ser ut att ha fastnat på "Installera paketen" eller "Läser in... Tjänsterna startar" eller "Vissa eller alla tjänster ligger nere". Övervakning av operativsystemets start från den virtuella konsolen visar att Docker Application Container Engine-tjänsten inte startar. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Installationen startas om för att initiera och aktivera de uppgraderade paketen när uppdateringen till version 4.4.0 har slutförts. Under normala omständigheter läser TUI (Text User Interface) in kärntjänsterna vid start och uppgiften efter uppgraderingen slutför uppgraderingen.

 

Det noteras dock i vissa fall att Docker Application Container Engine-tjänsten inte startar efter den första omstarten. I dessa fall kan följande ses:

 

Webbanvändargränssnittet har fastnat med meddelandet "Installerar paketet..." i flera timmar.

OpenManage Enterprise-webbanvändargränssnitt som indikerar att uppdateringen installerar paket

 

Du har nu möjlighet web användargränssnitt fastnade med meddelandet 'Laddar... Tjänsterna startar." i flera timmar.

OpenManage Enterprise-webbanvändargränssnitt som indikerar att uppgraderingen läses in och starttjänster startas

 

Den virtuella installationskonsolen visar att docker-tjänsten inte startar.

OpenManage Enterprise-konsolen för virtuella datorer som indikerar att det inte gick att starta Docker Application Container Engine

 

Textanvändargränssnittet (TUI) läses in när tidsgränsen för tjänststart har överskridits. Men webbgränssnittet visar "Vissa eller alla tjänster är nere." och TUI-enhetens statusfönster indikerar flera tjänster som "inaktiva".

OpenManage Enterprise-webbanvändargränssnitt som indikerar att några av alla tjänster är nere

 

Om du startar TUI, väljer "Visa aktuell enhetsstatus" och sedan väljer "Fortsätt" visas de flesta tjänster som inaktiva.

OpenManage Enterprise-text användargränssnitt Programstatusfönster som visar flera kärntjänster i inaktivt läge

Cause

OpenManage Enterprise använder Docker för att virtualisera (behålla) flera kärnprogram. Docker använder ett internt gränssnitt för att tillåta nätverkskommunikation för dessa containerbaserade program. Under initieringen flyttas Docker-gränssnittet till en dedikerad brandväggszon för att isolera den här trafiken från det primära gränssnittet.

 

Men när du har slutfört en tidigare uppgradering till antingen version 4.2.x eller 4.3.x flyttas Docker-gränssnittet från den dedikerade zonen. Detta tillåter inte nätverkskommunikation och stör starten av tjänsten nästa gång tjänsten uppdateras.

 

Om en omstart av installationen inte utlöses mellan den föregående och den aktuella uppdateringskörningen startar inte Docker-tjänsten och installationen är otillgänglig.

Resolution

Från och med den 1 maj 2025 har uppgraderingen 4.4.0 tagits bort från OpenManage Enterprise-uppdateringskatalogen online. Uppgraderingsversionen 4.4.1, som släpptes den 23 maj 2025, innehåller Docker-gränssnittskorrigeringen. Nya distributioner av OpenManage Enterprise version 4.4.0-enheten påverkas inte och är fortfarande tillgängliga för nedladdning på www.dell.com. Om du har uppgraderat till version 4.4.0 behöver du inte göra något mer.

Affected Products

Dell EMC OpenManage Enterprise, OpenManage Enterprise APEX AIOps Observability, OpenManage Enterprise Operations Manager, OpenManage Enterprise VMM and Configuration Manager, OpenManage Enterprise Integration for VMware vCenter , Dell EMC OpenManage Enterprise Power Manager, OpenManage Enterprise Services, OpenManage Enterprise SupportAssist, OpenManage Enterprise Update Manager ...
Article Properties
Article Number: 000312379
Article Type: Solution
Last Modified: 23 May 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.