PowerProtect Data Manager: Prestatieverbeteringen voor SQL Table Restore

Summary: Dit Knowledge Base-artikel is bedoeld voor het implementeren van mogelijke verbeteringen aan de SQL-tabelherstel voor grote databases.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerProtect Data Manager SQL Table Level Restore (TLR) voor 1,4 TB database duurt meer dan 8 uur.

Het tabelherstelproces leest de databasebestanden en reconstrueert de database met behulp van ItemPoint terwijl deze is gekoppeld vanuit het Data Domain.

Een volledig databaseherstel omvat daarentegen niet de datamining-activiteit, die bijdraagt aan het verschil in prestaties.

 

Cause

De NWFS-prestatiefunctie genaamd "direct IO" inschakelen verbetert de prestaties.

Dit kan worden gebruikt bij herstel op tabelniveau vanaf volledige back-ups.

Bij herstel op tabelniveau vanuit de back-up van transactielogboeken kan IttemPoint de back-upbestanden niet openen.
Fout uitgang

Met 'NWFS direct IO.' ItemPoint is niet in staat om alle bestanden van volledige en alle back-ups van transactielogboeken te laden.

Opmerking: Het is vereist om te upgraden naar 19.22 bij het uitvoeren van TLR met TLOG's met behulp van "NWFS direct IO".

 

Resolution

Om het volgende in te schakelen:

  1. Open de Register-editor
  2. Open het pad "SOFTWARE\EMC\DDBMSS\NWFS" of maak het pad als het niet bestaat.
  3. Maak de register-STRING-waarde "EnableDirectIO" en stel deze in op "TRUE"

Kijk naar het volgende bericht in het logboek van de nwfs.raw om te controleren of de instelling werkt.

2025-07-30T06:15:09.408Z  1753856109 0 1 0 0 6048 7424 0 sql01.amer.lan (pid7424) PowerProtect Data Manager notice 28 Using NWFS direct IO feature 0

 

Affected Products

PowerProtect Data Manager
Article Properties
Article Number: 000361896
Article Type: Solution
Last Modified: 03 Sep 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.