NetWorker:VSSを使用すると、クライアントのアップグレード後にファイルシステムのバックアップが失敗する

Summary: NetWorkerクライアントをアップグレードした後、VSS(ボリューム シャドウ コピー サービス)を有効にすると、ファイル システムのバックアップが失敗します。この問題は、VSS初期化プロセス中にNetWorkerのインストール パスが正しく配置されないことに関連しています。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • ファイルシステムのバックアップは、VSSが有効になっている場合にのみ失敗します。
  • VSSが無効になっている場合、バックアップは正常に完了します。
  • デバッグ ログに次のエラーが表示されます。
    save-D3 Unable to find NetWorker install directory.
    save-D9 PopulateSupportedWriterList() Exit.
    save: Cannot back up the volume save set because the initialization of VSS did not succeed.
    
  • すべてのVSSライターは安定した状態です。
  • シャドウ コピーが存在しない。
  • 手動によるVSSシャドウ作成は、OSレベルで機能します。
  • Windowsイベント ビューアーにVSS関連のエラーは見つかりません。

Cause

VSSが有効なバックアップ中に、NetWorkerは、包含/除外コンポーネント リストを処理するために、サポートされているライターのリストを取得しようとします。

NetWorkerのインストール ディレクトリーが見つからないために障害が発生し、VSSの初期化が失敗します。 

Resolution

NetWorkerクライアントのインストールを修復します。

  • 標準クライアントで問題が発生する場合は、 NetWorkerクライアント パッケージの修復を実行します。
  • (クライアントとして追加された )NetWorkerサーバー で問題が発生した場合は、 完全なNetWorkerインストール パッケージの修復を実行します。

Affected Products

NetWorker Family, NetWorker
Article Properties
Article Number: 000381651
Article Type: Solution
Last Modified: 27 Oct 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.