NVP vProxy: vProxy Does Not Appear When Performing An Emergency Recovery

Summary: During a VMware vCenter Emergency Restore, the NetWorker VMware Protection (NVP) vProxy appliance does not appear.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker VMware Protection integration is configured with the vProxy Appliance.  An Emergency Recovery to an ESXi host is being performed, but the vProxy that resides on that ESXi host does not appear under the option: "take control of an existing proxy already deployed within the vCenter."  You cannot use the option: "Use a proxy already deployed in the ESXi host but not registered with NetWorker."  If the vProxy is already registered to NetWorker, it reports "There is already a 'NSR VMware Proxy' with the name vproxy_name."

Cause

The vProxy may not appear under 'take control of an existing proxy' if the virtual machine's Notes field was modified in VMware or vSphere.

Resolution

1. Log in to the vCenter through the vSphere web client with an administrative account.
2. Select the vProxy VM from your inventory and open the "Summary" tab.
3. Check the "Notes" field. This field should only contain the following:

This is Backup and Recovery vProxy Appliance
4. If this field contains anything else use the Edit option to change it to the above value that matches your vProxy version.
This is Backup and Recovery vProxy Appliance
5. Restart the Emergency Recovery and select the vProxy.

Additional Information

The notes field of 2.0.x vProxies (and earlier) stated "This is EMC Backup and Recovery vProxy Appliance". 2.x vProxies are end of support life (EOSL). The vProxy appliance should be the latest minor release supported by the NetWorker server. 

 

See the NetWorker Compatibility Matrix to determine vProxy and VMware support requirements: https://elabnavigator.dell.com/eln/modernHomeAutomatedTiles?page=NetWorker

NVP vProxy: NetWorker vProxy Version Information

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000160519
Article Type: Solution
Last Modified: 05 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.