NVE: Upgrade fehlgeschlagen: ungültige Bytesequenz in UTF-8

Summary: Upgrade der NetWorker Virtual Edition (NVE) schlug fehl und meldet "Die Standard-Serverschutz-Policy ist beschädigt oder nicht vorhanden. Validieren Sie den Serverschutz, bevor Sie mit dem Upgrade fortfahren. - Operation fehlgeschlagen" ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Beim Upgrade der NVE-Appliance (NetWorker Virtual Edition) schlägt das Upgrade fehl. Der folgende Fehler wird in den NVE's gefunden /data01/avamar/repo/temp/*/tmp/workflow.logverwalten:

2023-01-09 15:04:05 (+0100) 47081677224620 INFO: ---------- BEGIN ValidateServerProtectionPolicy::do ----------
2023-01-09 15:04:05 (+0100) 47081677224620 INFO: >>> [make_temp_script] 222 very_current_user=root, as_user=root, ssh command is: (nsradmin -s 127.0.0.1 -i /space/avamar/repo/temp/NveUpgrade-19.8.0-23.avp_1673272933099/tmp/nsr-config.txt) >/usr/local/avamar/var/run_command-sysout.28416.47081677224620 2>&1
2023-01-09 15:04:05 (+0100) 47081677224620 ERROR: ERROR: invalid byte sequence in UTF-8
2023-01-09 15:04:05 (+0100) 47081677224620 DETAILS: ERROR: invalid byte sequence in UTF-8

Cause

Es gab ein Nicht-UTF-8-Zeichen "Â" im Feld "Benachrichtigungen" aus der Server-Schutzrichtlinie:

mail -h smtp.domain.com -s 'Networker Bootstrap Recovery Clone failed' backupadmin@email.com

Es scheint, dass der Befehl von einem anderen Ort kopiert und eingefügt wurde und ein Nicht-UTF-8-Zeichen enthält.

Dieses Feld unterstützt keine Nicht-UTF-8-Zeichen, was der Grund für den Fehler war.

Resolution

  1. Öffnen Sie die NetWorker Management Console (NMC).
  2. Navigieren Sie zur Policy Server Protection auf der Registerkarte Protection .
  3. Klicken Sie mit der rechten Maustaste auf Server Protection Policy.
  4. Löschen Sie den Benachrichtigungsbefehl aus dem Benachrichtigungsfeld und geben Sie ihn manuell erneut ein, um nicht unterstützte Zeichen zu vermeiden, klicken Sie auf die Schaltfläche OK.
  5. Gehen Sie zurück zum Installationsmanager und klicken Sie auf die Schaltfläche "Erneut versuchen".

Additional Information

Affected Products

NetWorker Family, NetWorker

Products

NetWorker Series
Article Properties
Article Number: 000208045
Article Type: Solution
Last Modified: 16 May 2026
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.