RecoverPoint for VMs: Upgrade z verze 5.3.0.x nebo 5.3.1.0 může přestat reagovat při 11 nebo 84 %
Summary:
Upgrade z verze RecoverPoint for VMs 5.3.0.x nebo 5.3.1.0 může selhat s možnou chybou: „Error: Upgrade had failed. Pokud upgrade stále selhává, obraťte se na zákaznickou podporu. vRPA
není nahoře"
...
Symptoms
Existuje několik různých možných příznaků ze stejné hlavní příčiny:
Příznak 1:
Aktualizace balíčku Debian neproběhla, i když instalační protokoly říkají, že proběhla úspěšně.
Příznak 2:
Po restartování se nespustila služba Tomcat.
Příznak 3:
V protokolech ClusterLogic v RPA1 nebo RPA2 se zobrazuje jedna nebo více z následujících zpráv:
ERROR - Failed to connect to vRPA with IP <IP>. com.sun.xml.ws.client.ClientTransportException: HTTP transport error: java.net.ConnectException: Connection refused (Connection refused)
ERROR - UpgradeRemoteRPATask :Task failed: Upgrading vRPA number <RPA NUMBER>. com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException: vRPA <IP> is not up.
Příznak 4:
V uživatelském rozhraní se zobrazují následující zprávy:
The error seen in UI is "Error: Upgrade had failed. If upgrade keeps failing, contact customer support. vRPA <IP> is not up"
Cause
Během aktualizace RPA se nainstalují balíčky Debianu (.deb soubory) a provede
se restart.Instalace balíčku běží na pozadí, které může být přerušeno restartem v dalším kroku upgradu.
Vzhledem k tomu, že instalační program je ukončen před dokončením, služba tomcat8.service nemusí být dostupná v adresáři systemd, což má za následek selhání restartování tomcat8 a nedostupnost RPA.
Resolution
Preventivní zástupné řešení:
Před upgradem se ke každému RPA přihlaste jako uživatel admin a spusťte následující podepsaný skript ([2] Setup -> [8] Advanced options -> [4] Run script
OTBkOWY0ZDA1MjMxODMxNWM2NTJkMjZjOGYyM2E1MWQKdW5saW1pdGVkCm5vdF9yZXN0cmljdGVk ClRoZSBpZCBvZiB0aGUgc2NyaXB0IGlzOlJQLTMxNzE4CkFkZHMgc2xlZXAgdG8gYWxsb3cgdXBn cmFkZSB0byBjb21wbGV0ZQpBc3NpZiBIYWwKVkVSU0lPTj0kKGdyZXAgdF92ZXJzaW9uX2Z1bGwg L2hvbWUva29zL2tib3gvc3JjL2luaXRpYWxpemF0aW9uL3R3ZWFrX3BhcmFtcy90d2Vhay5wYXJh bXMudmVyc2lvbnxncmVwIC1vICJbMS05XS4qWzAtOV0iKQpNQUpPUlZFUlNJT049JChlY2hvICIk VkVSU0lPTiJ8YXdrIC1GICIuIiAne3ByaW50ICQxfScpCk1JTk9SVkVSU0lPTj0kKGVjaG8gIiRW RVJTSU9OInxhd2sgLUYgIi4iICd7cHJpbnQgJDJ9JykKU1BWRVJTSU9OPSQoZWNobyAiJFZFUlNJ T04ifGF3ayAtRiAiLiIgJ3twcmludCAkM30nKQpQQVRDSFZFUlNJT049JChlY2hvICIkVkVSU0lP TiJ8YXdrIC1GICIuIiAne3ByaW50ICQ0fScpCmlmIChbICRNQUpPUlZFUlNJT04gLWVxIDUgXSAm JiBbICRNSU5PUlZFUlNJT04gLWVxIDMgXSAmJiBbICRTUFZFUlNJT04gLWVxIDAgXSkgfHwgKFsg JE1BSk9SVkVSU0lPTiAtZXEgNSBdICYmIFsgJE1JTk9SVkVSU0lPTiAtZXEgMyBdICYmIFsgJFNQ VkVSU0lPTiAtZXEgMSBdICYmIFsgJFBBVENIVkVSU0lPTiAtZXEgMCBdKTsKCXRoZW4KCQlpZiBb IGBncmVwICJzbGVlcCA2MDAiIC9ob21lL2tvcy9rYm94L3NyYy9pbnN0YWxsYXRpb24vZGlzdHJp YnV0aW9uL2lzb19zZXJ2aWNlcy5zaHx3YyAtbGAgLWVxIDAgXTsKCQkJdGhlbgoJCQkJc2VkIC1p ICcxODYgaSBzbGVlcCA2MDAnIC9ob21lL2tvcy9rYm94L3NyYy9pbnN0YWxsYXRpb24vZGlzdHJp YnV0aW9uL2lzb19zZXJ2aWNlcy5zaAoJCQkJc2VkIC1pICJzL3NsZWVwIDYwMC8gICBzbGVlcCA2 MDAvIiAvaG9tZS9rb3Mva2JveC9zcmMvaW5zdGFsbGF0aW9uL2Rpc3RyaWJ1dGlvbi9pc29fc2Vy dmljZXMuc2gKCQkJCWVjaG8gIkNoYW5nZXMgYXBwbGllZCBzdWNjZXNzZnVsbHkgdG8gaXNvX3Nl cnZpY2VzLnNoLiIKCQllbHNlCgkJCWVjaG8gIlZhbHVlIGFscmVhZHkgYWRkZWQuIE5vIGNoYW5n ZXMgbWFkZS4iCgkJZmkKZWxzZQoJZWNobyAiTm8gbmVlZCB0byBydW4gdGhpcyBzY3JpcHQgb24g dGhpcyB2ZXJzaW9uLiBObyBjaGFuZ2VzIG1hZGUuIgpmaQo= #
Usnesení:
Tento problém je vyřešen ve verzi kódu RecoverPoint 5.3 SP1 Patch 1 a novějších.
Upgrade z verze 5.3 SP1 P1 a novější by měl tomuto problému zabránit.
Additional Information
Další informace získáte v článku Jira číslo závady RP-31718. Přístup k JIRA je k dispozici pouze oprávněným zástupcům zákaznického servisu.