RecoverPoint para máquinas virtuales: La actualización desde 5.3.0.x o 5.3.1.0 puede dejar de responder en un 11 % o un 84 %

Summary: La actualización desde RecoverPoint para las VM 5.3.0.x o 5.3.1.0 puede fallar con un posible error: "Error: Upgrade had failed. Si la actualización continúa fallando, póngase en contacto con el soporte al cliente. vRPA no está arriba" ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Hay varios síntomas posibles diferentes de la misma causa raíz:

Síntoma 1:
La actualización del paquete Debian no se realizó a pesar de que los registros de instalación dicen que se realizó correctamente.

Síntoma 2:
el servicio Tomcat no apareció después del reinicio.

Síntoma 3:
Uno o más de los siguientes mensajes se observan en los registros de clusterLogic en RPA1 o RPA2:

ERROR - Failed to connect to vRPA with IP <IP>.
com.sun.xml.ws.client.ClientTransportException: HTTP transport error: java.net.ConnectException: Connection refused (Connection refused)
ERROR - UpgradeRemoteRPATask :Task failed: Upgrading vRPA number <RPA NUMBER>.
com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException: vRPA <IP> is not up.

Síntoma 4:
se muestran los siguientes mensajes en la interfaz de usuario:

The error seen in UI is "Error: Upgrade had failed. If upgrade keeps failing, contact customer support. vRPA <IP> is not up"

 

Cause

Cuando se actualiza el RPA, se instalan los paquetes Debian (archivos .deb) y se realiza un reinicio.
La instalación del paquete se ejecuta en segundo plano, lo cual puede ser anulado por el reinicio en el siguiente paso de la actualización.
Debido a que el instalador se elimina antes de completarse, es posible que tomcat8.service no esté disponible en el directorio systemd, lo que provoca que no se pueda reiniciar tomcat8 y que no se pueda acceder al RPA.

 

Resolution

Solución alternativa preventiva:
Inicie sesión como usuario administrador en cada RPA antes de la actualización y ejecute el siguiente script firmado ([2] Configuración -> [8] Opciones avanzadas -> [4] Ejecutar script

OTBkOWY0ZDA1MjMxODMxNWM2NTJkMjZjOGYyM2E1MWQKdW5saW1pdGVkCm5vdF9yZXN0cmljdGVk
ClRoZSBpZCBvZiB0aGUgc2NyaXB0IGlzOlJQLTMxNzE4CkFkZHMgc2xlZXAgdG8gYWxsb3cgdXBn
cmFkZSB0byBjb21wbGV0ZQpBc3NpZiBIYWwKVkVSU0lPTj0kKGdyZXAgdF92ZXJzaW9uX2Z1bGwg
L2hvbWUva29zL2tib3gvc3JjL2luaXRpYWxpemF0aW9uL3R3ZWFrX3BhcmFtcy90d2Vhay5wYXJh
bXMudmVyc2lvbnxncmVwIC1vICJbMS05XS4qWzAtOV0iKQpNQUpPUlZFUlNJT049JChlY2hvICIk
VkVSU0lPTiJ8YXdrIC1GICIuIiAne3ByaW50ICQxfScpCk1JTk9SVkVSU0lPTj0kKGVjaG8gIiRW
RVJTSU9OInxhd2sgLUYgIi4iICd7cHJpbnQgJDJ9JykKU1BWRVJTSU9OPSQoZWNobyAiJFZFUlNJ
T04ifGF3ayAtRiAiLiIgJ3twcmludCAkM30nKQpQQVRDSFZFUlNJT049JChlY2hvICIkVkVSU0lP
TiJ8YXdrIC1GICIuIiAne3ByaW50ICQ0fScpCmlmIChbICRNQUpPUlZFUlNJT04gLWVxIDUgXSAm
JiBbICRNSU5PUlZFUlNJT04gLWVxIDMgXSAmJiBbICRTUFZFUlNJT04gLWVxIDAgXSkgfHwgKFsg
JE1BSk9SVkVSU0lPTiAtZXEgNSBdICYmIFsgJE1JTk9SVkVSU0lPTiAtZXEgMyBdICYmIFsgJFNQ
VkVSU0lPTiAtZXEgMSBdICYmIFsgJFBBVENIVkVSU0lPTiAtZXEgMCBdKTsKCXRoZW4KCQlpZiBb
IGBncmVwICJzbGVlcCA2MDAiIC9ob21lL2tvcy9rYm94L3NyYy9pbnN0YWxsYXRpb24vZGlzdHJp
YnV0aW9uL2lzb19zZXJ2aWNlcy5zaHx3YyAtbGAgLWVxIDAgXTsKCQkJdGhlbgoJCQkJc2VkIC1p
ICcxODYgaSBzbGVlcCA2MDAnIC9ob21lL2tvcy9rYm94L3NyYy9pbnN0YWxsYXRpb24vZGlzdHJp
YnV0aW9uL2lzb19zZXJ2aWNlcy5zaAoJCQkJc2VkIC1pICJzL3NsZWVwIDYwMC8gICBzbGVlcCA2
MDAvIiAvaG9tZS9rb3Mva2JveC9zcmMvaW5zdGFsbGF0aW9uL2Rpc3RyaWJ1dGlvbi9pc29fc2Vy
dmljZXMuc2gKCQkJCWVjaG8gIkNoYW5nZXMgYXBwbGllZCBzdWNjZXNzZnVsbHkgdG8gaXNvX3Nl
cnZpY2VzLnNoLiIKCQllbHNlCgkJCWVjaG8gIlZhbHVlIGFscmVhZHkgYWRkZWQuIE5vIGNoYW5n
ZXMgbWFkZS4iCgkJZmkKZWxzZQoJZWNobyAiTm8gbmVlZCB0byBydW4gdGhpcyBzY3JpcHQgb24g
dGhpcyB2ZXJzaW9uLiBObyBjaGFuZ2VzIG1hZGUuIgpmaQo=
#

Resolución:
Este problema se resuelve en el parche 1 de RecoverPoint 5.3 SP1 y en las versiones de código posteriores.
La actualización desde 5.3 SP1 P1 y versiones posteriores debería evitar que se produzca el problema.

 

Additional Information

Nota:
Para obtener más información, consulte el número de defecto de Jira RP-31718. El acceso a JIRA solo está disponible para representantes autorizados de servicio al cliente.

 

Products

RecoverPoint for Virtual Machines
Article Properties
Article Number: 000182751
Article Type: Solution
Last Modified: 20 Jan 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.