RecoverPoint for VMs:從 5.3.0.x 或 5.3.1.0 升級可能會於 11% 或 84% 停止回應

Summary: 從 VMs 5.3.0.x 或 5.3.1.0 的 RecoverPoint 升級可能會失敗,並出現可能的錯誤:「Error: Upgrade had failed.如果升級仍失敗,請聯絡客戶支援。vRPA 不上”

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

同一根本原因可能出現幾種不同的症狀:

癥狀 1:
即使安裝日誌顯示 Debian 軟體包升級成功,但仍未完成。

症狀 2:
重新開機後未出現 Tomcat 服務。

症狀 3:
在 RPA1 或 RPA2 的 clusterLogic 記錄中看到下列一或多則訊息:

ERROR - Failed to connect to vRPA with IP <IP>.
com.sun.xml.ws.client.ClientTransportException: HTTP transport error: java.net.ConnectException: Connection refused (Connection refused)
ERROR - UpgradeRemoteRPATask :Task failed: Upgrading vRPA number <RPA NUMBER>.
com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException: vRPA <IP> is not up.

症狀 4:
UI 上會出現下列訊息:

The error seen in UI is "Error: Upgrade had failed. If upgrade keeps failing, contact customer support. vRPA <IP> is not up"

 

Cause

當 RPA 正在升級時,會安裝 Debian 軟體包 (.deb檔) 並執行重新開機。
套件安裝會在背景執行,可能會在下一個升級步驟中因重新開機而中止。
由於安裝程式在完成前已終止,因此 tomcat8.service 可能無法在系統目錄中使用,導致無法重新啟動 tomcat8,並導致無法連線 RPA。

 

Resolution

預防性因應措施:
升級前,請以系統管理員使用者身分登入每個 RPA,並執行下列簽署的指令檔 ([2] 設定 -> [8] 進階選項 -> [4] 執行指令檔

OTBkOWY0ZDA1MjMxODMxNWM2NTJkMjZjOGYyM2E1MWQKdW5saW1pdGVkCm5vdF9yZXN0cmljdGVk
ClRoZSBpZCBvZiB0aGUgc2NyaXB0IGlzOlJQLTMxNzE4CkFkZHMgc2xlZXAgdG8gYWxsb3cgdXBn
cmFkZSB0byBjb21wbGV0ZQpBc3NpZiBIYWwKVkVSU0lPTj0kKGdyZXAgdF92ZXJzaW9uX2Z1bGwg
L2hvbWUva29zL2tib3gvc3JjL2luaXRpYWxpemF0aW9uL3R3ZWFrX3BhcmFtcy90d2Vhay5wYXJh
bXMudmVyc2lvbnxncmVwIC1vICJbMS05XS4qWzAtOV0iKQpNQUpPUlZFUlNJT049JChlY2hvICIk
VkVSU0lPTiJ8YXdrIC1GICIuIiAne3ByaW50ICQxfScpCk1JTk9SVkVSU0lPTj0kKGVjaG8gIiRW
RVJTSU9OInxhd2sgLUYgIi4iICd7cHJpbnQgJDJ9JykKU1BWRVJTSU9OPSQoZWNobyAiJFZFUlNJ
T04ifGF3ayAtRiAiLiIgJ3twcmludCAkM30nKQpQQVRDSFZFUlNJT049JChlY2hvICIkVkVSU0lP
TiJ8YXdrIC1GICIuIiAne3ByaW50ICQ0fScpCmlmIChbICRNQUpPUlZFUlNJT04gLWVxIDUgXSAm
JiBbICRNSU5PUlZFUlNJT04gLWVxIDMgXSAmJiBbICRTUFZFUlNJT04gLWVxIDAgXSkgfHwgKFsg
JE1BSk9SVkVSU0lPTiAtZXEgNSBdICYmIFsgJE1JTk9SVkVSU0lPTiAtZXEgMyBdICYmIFsgJFNQ
VkVSU0lPTiAtZXEgMSBdICYmIFsgJFBBVENIVkVSU0lPTiAtZXEgMCBdKTsKCXRoZW4KCQlpZiBb
IGBncmVwICJzbGVlcCA2MDAiIC9ob21lL2tvcy9rYm94L3NyYy9pbnN0YWxsYXRpb24vZGlzdHJp
YnV0aW9uL2lzb19zZXJ2aWNlcy5zaHx3YyAtbGAgLWVxIDAgXTsKCQkJdGhlbgoJCQkJc2VkIC1p
ICcxODYgaSBzbGVlcCA2MDAnIC9ob21lL2tvcy9rYm94L3NyYy9pbnN0YWxsYXRpb24vZGlzdHJp
YnV0aW9uL2lzb19zZXJ2aWNlcy5zaAoJCQkJc2VkIC1pICJzL3NsZWVwIDYwMC8gICBzbGVlcCA2
MDAvIiAvaG9tZS9rb3Mva2JveC9zcmMvaW5zdGFsbGF0aW9uL2Rpc3RyaWJ1dGlvbi9pc29fc2Vy
dmljZXMuc2gKCQkJCWVjaG8gIkNoYW5nZXMgYXBwbGllZCBzdWNjZXNzZnVsbHkgdG8gaXNvX3Nl
cnZpY2VzLnNoLiIKCQllbHNlCgkJCWVjaG8gIlZhbHVlIGFscmVhZHkgYWRkZWQuIE5vIGNoYW5n
ZXMgbWFkZS4iCgkJZmkKZWxzZQoJZWNobyAiTm8gbmVlZCB0byBydW4gdGhpcyBzY3JpcHQgb24g
dGhpcyB2ZXJzaW9uLiBObyBjaGFuZ2VzIG1hZGUuIgpmaQo=
#

主意:
此問題已在 RecoverPoint 5.3 SP1 修補程式 1 及更新程式碼版本中解決。
5.3 SP1 P1 及更新版本升級應可防止問題發生。

 

Additional Information

便條:
如需更多資訊,請參閱 JIRA 缺陷編號 RP-31718。Jira 存取權僅提供給授權的客戶服務代表。

 

Products

RecoverPoint for Virtual Machines
Article Properties
Article Number: 000182751
Article Type: Solution
Last Modified: 20 Jan 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.