RecoverPoint for VMs:从 5.3.0.x 或 5.3.1.0 升级可能会在 11% 或 84% 处停止响应
Summary:
从 RecoverPoint for VMs 5.3.0.x 或 5.3.1.0 升级可能会失败,并可能出现错误:“Error: Upgrade had failed.如果升级仍然失败,请联系客户支持。vRPA 不起来”
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
同一根本原因可能有几种不同的症状:
症状 1:
即使安装日志显示升级成功,Debian 软件包升级仍未完成。
症状 2:
重新启动后 Tomcat 服务未出现。
症状 3:
RPA1 或 RPA2 的 clusterLogic 日志中显示以下一条或多条消息:
ERROR - Failed to connect to vRPA with IP <IP>. com.sun.xml.ws.client.ClientTransportException: HTTP transport error: java.net.ConnectException: Connection refused (Connection refused)
ERROR - UpgradeRemoteRPATask :Task failed: Upgrading vRPA number <RPA NUMBER>. com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException: vRPA <IP> is not up.
症状 4:
UI 上显示以下消息:
The error seen in UI is "Error: Upgrade had failed. If upgrade keeps failing, contact customer support. vRPA <IP> is not up"
Cause
升级 RPA 时,将安装 Debian 软件包(.deb 文件)并重新启动。
软件包安装在后台运行,在升级的下一步中,重新启动可能会中止。
由于安装程序在完成之前已终止,因此 tomcat8.service 可能在 systemd 目录中不可用,从而导致重新启动 tomcat8 失败并导致 RPA 无法访问。
Resolution
预防性解决方法:
在升级之前,以管理员用户身份登录每个 RPA,并运行以下签名脚本 ([2] 设置 -> [8] 高级选项 -> [4] 运行脚本
OTBkOWY0ZDA1MjMxODMxNWM2NTJkMjZjOGYyM2E1MWQKdW5saW1pdGVkCm5vdF9yZXN0cmljdGVk ClRoZSBpZCBvZiB0aGUgc2NyaXB0IGlzOlJQLTMxNzE4CkFkZHMgc2xlZXAgdG8gYWxsb3cgdXBn cmFkZSB0byBjb21wbGV0ZQpBc3NpZiBIYWwKVkVSU0lPTj0kKGdyZXAgdF92ZXJzaW9uX2Z1bGwg L2hvbWUva29zL2tib3gvc3JjL2luaXRpYWxpemF0aW9uL3R3ZWFrX3BhcmFtcy90d2Vhay5wYXJh bXMudmVyc2lvbnxncmVwIC1vICJbMS05XS4qWzAtOV0iKQpNQUpPUlZFUlNJT049JChlY2hvICIk VkVSU0lPTiJ8YXdrIC1GICIuIiAne3ByaW50ICQxfScpCk1JTk9SVkVSU0lPTj0kKGVjaG8gIiRW RVJTSU9OInxhd2sgLUYgIi4iICd7cHJpbnQgJDJ9JykKU1BWRVJTSU9OPSQoZWNobyAiJFZFUlNJ T04ifGF3ayAtRiAiLiIgJ3twcmludCAkM30nKQpQQVRDSFZFUlNJT049JChlY2hvICIkVkVSU0lP TiJ8YXdrIC1GICIuIiAne3ByaW50ICQ0fScpCmlmIChbICRNQUpPUlZFUlNJT04gLWVxIDUgXSAm JiBbICRNSU5PUlZFUlNJT04gLWVxIDMgXSAmJiBbICRTUFZFUlNJT04gLWVxIDAgXSkgfHwgKFsg JE1BSk9SVkVSU0lPTiAtZXEgNSBdICYmIFsgJE1JTk9SVkVSU0lPTiAtZXEgMyBdICYmIFsgJFNQ VkVSU0lPTiAtZXEgMSBdICYmIFsgJFBBVENIVkVSU0lPTiAtZXEgMCBdKTsKCXRoZW4KCQlpZiBb IGBncmVwICJzbGVlcCA2MDAiIC9ob21lL2tvcy9rYm94L3NyYy9pbnN0YWxsYXRpb24vZGlzdHJp YnV0aW9uL2lzb19zZXJ2aWNlcy5zaHx3YyAtbGAgLWVxIDAgXTsKCQkJdGhlbgoJCQkJc2VkIC1p ICcxODYgaSBzbGVlcCA2MDAnIC9ob21lL2tvcy9rYm94L3NyYy9pbnN0YWxsYXRpb24vZGlzdHJp YnV0aW9uL2lzb19zZXJ2aWNlcy5zaAoJCQkJc2VkIC1pICJzL3NsZWVwIDYwMC8gICBzbGVlcCA2 MDAvIiAvaG9tZS9rb3Mva2JveC9zcmMvaW5zdGFsbGF0aW9uL2Rpc3RyaWJ1dGlvbi9pc29fc2Vy dmljZXMuc2gKCQkJCWVjaG8gIkNoYW5nZXMgYXBwbGllZCBzdWNjZXNzZnVsbHkgdG8gaXNvX3Nl cnZpY2VzLnNoLiIKCQllbHNlCgkJCWVjaG8gIlZhbHVlIGFscmVhZHkgYWRkZWQuIE5vIGNoYW5n ZXMgbWFkZS4iCgkJZmkKZWxzZQoJZWNobyAiTm8gbmVlZCB0byBydW4gdGhpcyBzY3JpcHQgb24g dGhpcyB2ZXJzaW9uLiBObyBjaGFuZ2VzIG1hZGUuIgpmaQo= #
分辨率:
此问题已在 RecoverPoint 5.3 SP1 修补程序 1 和更高代码版本中得到解决。
从 5.3 SP1 P1 和更高版本升级应该会阻止此问题的发生。
Additional Information
注意:
有关更多信息,请参阅 Jira 缺陷编号 RP-31718。仅授权客户服务代表才具有 Jira 访问权限。
有关更多信息,请参阅 Jira 缺陷编号 RP-31718。仅授权客户服务代表才具有 Jira 访问权限。
Products
RecoverPoint for Virtual MachinesArticle Properties
Article Number: 000182751
Article Type: Solution
Last Modified: 20 Jan 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.