NetWorker: NMC response slows down or stops responding due to large stat.db

Summary: NMC response slows down and or stops responding.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • NetWorker Management Console (NMC) response slows down or stops responding.
  • The top command, or Windows Task Manager "Details" tab shows the process nsrsqliteasm occupies 99% CPU resource when the NMC stops responding

Cause

The stat.db on the NetWorker server is large (for example, several GB):

  • Linux: /nsr/res/statistics/stat.db
  • Windows (Default): C:\Program Files\EMC NetWorker\nsr\res\statistics\stat.db

Resolution

The following process removes the NetWorker server's corrupted storage node resources and re-creates a new storage node resource:

  1. Perform a Server Protection -> Server backup.
    1. If the NMC is not functional, run the following command from an elevated prompt on the NetWorker server: nsrpolicy start -p "Server Protection" -w "Server backup"
    2. Monitor the backup session using the nsrwatch command.
  2. From an elevated prompt on the NetWorker server, collect bootstrap details: mminfo -B
  3. Stop NetWorker services:
  • Linux: nsr_shutdown or systemctl stop networker
  • Windows: net stop nsrd
    1. Delete or rename the stat.db file:
    • Linux: /nsr/res/statistics/stat.db
    • Windows (Default): C:\Program Files\EMC NetWorker\nsr\res\statistics\stat.db
    1. Rename the daemon.raw file:
    • Linux: /nsr/logs/daemon.raw
    • Windows (default): C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw
    1. Start NetWorker again:
    • Linux: systemctl start networker
    • Windows: net start nsrd
      • If the Windows NetWorker server is also the NetWorker Management Console (NMC) server, run: net start gstd

    Additional Information

    Affected Products

    NetWorker, NetWorker Management Console

    Products

    NetWorker Family
    Article Properties
    Article Number: 000193506
    Article Type: Solution
    Last Modified: 13 Feb 2026
    Version:  2
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