mtreeレプリケーションのインポートが失敗します。nsrmmdbd SQLITEの重大な制約が失敗しました

Summary: ターゲット サーバーのメディア データベースにすでに存在するセーブセットをインポートしようとすると、「nsrmmdbd SQLITEの重大な制約に失敗しました」というエラーが発生したため、Mtreeレプリケーションが失敗する

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

サーバーはDDデバイス レプリケーションを使用して構成されます。
バージョンは19.9.0.4以前です。
エクスポートは正常に動作しています。
インポートが失敗しています。

Cause

この問題が発生する可能性のあるシナリオは2つあります。
バージョン19.9.0.4以前のバグにより、サービスの再起動後に「NSR DDデバイス レプリケーション」リソースがサーバーから削除されることがあります。これにより、次の 2 つの状況が発生する可能性があります。
  1. ソース サーバーで、「NSR DDデバイス レプリケーション」リソースが削除されます。「最終レプリケーション時刻」の参照が失われます。次のエクスポート操作では、最後のエクスポート後にこれらのセーブセットはエクスポートされず、ボリューム内にあるすべてのセーブセットがエクスポートされます。インポート時に、これらのssidの多くはすでにインポートされているため、次のエラー メッセージが表示されます。SSIDを2回挿入できないため、SQLITEの重大な制約に失敗しました。
  2. ターゲット サーバーで、「NSR DDデバイス レプリケーション」リソースが削除されます。「最終レプリケーション時刻」の参照が失われます。前回のインポート時刻以降、次のインポート操作では新しいセーブセットはインポートされません。代わりに、すべてのセーブセットのインポートが試行されます。しかし、これらのセーブセットの多くはすでにインポートされているため、失敗します。

Resolution

この障害は「NSR DDデバイス レプリケーション」リソースが削除されていることに起因しているため、この問題を回避するための唯一の修正方法は、19.9.0.5または19.10にアップグレードすることです。

考えられる回避策:
回避策A:
1. nsr/nsrdb/dbgフォルダー2
にある「NSR DDデバイス レプリケーション」リソースから、「最後のレプリケーション」時刻を見つけます。既存の「NSR DDデバイス レプリケーション」を削除し、同じパラメーターを使用して新しいレプリケーションを作成しますが、上記の最後のレプリケーション時刻を使用します。

回避策B:
レプリケーションの開始以降、ターゲット サーバーの/nsr/replicationフォルダーの内容が変更されていない場合は、レプリケーション ボリューム全体を削除して、インポートを再度実行できます(NSR DDデバイス レプリケーションの最終レプリケーション時刻が0の場合のみ)。
セーブセットは読み取り専用の mtree 上にあるため、ターゲットの NetWorker サーバでは削除できないことに注意してください。したがって、ボリュームを削除しても、セーブセットは削除されません。その上、/nsr/replicationフォルダーはそのままなので、レプリケーション ジョブの開始以降にインポートされたすべてのセーブセットの情報があります。

回避策C:
リストアのためにターゲットサーバー上の特定のSSIDを取得する必要がある場合は、指定したSSIDに対してスキャナーを実行できます。
このSSIDはインポート操作ではなく「scanner」でインポートされたため、このSSIDをインポートしようとする後続のインポート操作は失敗します。リカバリーが完了したら、nsrmm -d -S ssidを使用して、後でセーブセットを手動で削除できます。この場合も、Data Domainからssidは削除されず、メディア データベース内の参照のみが削除されます。

Additional Information

この問題についてさらにサポートが必要な場合や理解が必要な場合は、 サポートにお問い合わせください。

Affected Products

NetWorker
Article Properties
Article Number: 000222759
Article Type: Solution
Last Modified: 07 Mar 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.