MTree 複寫匯入失敗:nsrmmdbd SQLITE 嚴重約束失敗
Summary: Mtree 複寫失敗,因為它嘗試匯入的目標伺服器媒體資料庫中已經存在的儲存集,導致錯誤:nsrmmdbd SQLITE 嚴重約束失敗
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
伺服器已使用 DD 裝置複寫進行設定。
版本為 19.9.0.4 或更低版本。
匯出運作正常。
匯入失敗。
版本為 19.9.0.4 或更低版本。
匯出運作正常。
匯入失敗。
Cause
在 2 種可能的情況下,可能會出現此問題。
由於版本 19.9.0.4 或更舊版本中的錯誤,在重新開機服務後,可能會從伺服器刪除「NSR DD 裝置複寫」資源。這可能會導致兩種情況:
由於版本 19.9.0.4 或更舊版本中的錯誤,在重新開機服務後,可能會從伺服器刪除「NSR DD 裝置複寫」資源。這可能會導致兩種情況:
- 在來源伺服器上,會刪除「NSR DD 裝置複寫」資源。遺失「上次複寫時間」的參照。下一個匯出操作不會在上次匯出後匯出這些集集,而只是匯出卷中的所有存儲集。在導入時,其中許多 ssid 之前已經導入,因此出現錯誤消息:SQLITE 嚴重約束失敗,因為我們無法插入 ssid 兩次。
- 在目標伺服器上,會刪除「NSR DD 裝置複寫」資源。遺失「上次複寫時間」的參照。下一次匯入作業將不會在上次匯入時間之後匯入新的集區。相反地,它會嘗試匯入所有集區。但其中許多集區已經匯入,因此將會失敗。
Resolution
由於故障源自於「NSR DD 裝置複寫」資源被刪除,唯一的修正方法是升級至 19.9.0.5 或 19.10,以避免發生此問題。
可能的因應措施:
因應措施 A:
1. 從 nsr/nsrdb/dbg 資料夾
2 中的「NSR DD 裝置複寫」資源中,找出哪個是「上次複寫」時間。刪除現有的「NSR DD 裝置複寫」,並使用相同的參數建立新的裝置,但使用上述的上次複寫時間。
解決辦法 B:
如果目標伺服器中 /nsr/replication 資料夾的內容自複製開始以來未被修改,則可以刪除整個複製卷,然後再次運行導入(僅當 NSR DD 設備複製的上次複製時間為 0 時)。
請記住,目標 NetWorker 伺服器無法刪除存儲集,因為它們位於唯讀 mtree 上;因此,刪除磁片區不會刪除集區。最重要的是,由於我們保存了完整的 /nsr/replication 資料夾,因此我們獲得了自複製工作啟動以來已匯入的所有存儲集的資訊。
解決方法 C:
如果需要在目標伺服器上檢索特定的 SSID 以進行還原,則可以為指定的 SSID 運行掃描程式。
由於此 SSID 是使用「掃描器」導入的,而不是通過導入操作導入的,因此嘗試導入此 SSID 的任何後續導入操作都將失敗。復原完儲存集後,您可以稍後使用 nsrmm -d -S ssid 手動刪除儲存集。同樣地,這不會從 Data Domain 刪除 ssid,只會刪除媒體資料庫中的參照。
可能的因應措施:
因應措施 A:
1. 從 nsr/nsrdb/dbg 資料夾
2 中的「NSR DD 裝置複寫」資源中,找出哪個是「上次複寫」時間。刪除現有的「NSR DD 裝置複寫」,並使用相同的參數建立新的裝置,但使用上述的上次複寫時間。
解決辦法 B:
如果目標伺服器中 /nsr/replication 資料夾的內容自複製開始以來未被修改,則可以刪除整個複製卷,然後再次運行導入(僅當 NSR DD 設備複製的上次複製時間為 0 時)。
請記住,目標 NetWorker 伺服器無法刪除存儲集,因為它們位於唯讀 mtree 上;因此,刪除磁片區不會刪除集區。最重要的是,由於我們保存了完整的 /nsr/replication 資料夾,因此我們獲得了自複製工作啟動以來已匯入的所有存儲集的資訊。
解決方法 C:
如果需要在目標伺服器上檢索特定的 SSID 以進行還原,則可以為指定的 SSID 運行掃描程式。
由於此 SSID 是使用「掃描器」導入的,而不是通過導入操作導入的,因此嘗試導入此 SSID 的任何後續導入操作都將失敗。復原完儲存集後,您可以稍後使用 nsrmm -d -S ssid 手動刪除儲存集。同樣地,這不會從 Data Domain 刪除 ssid,只會刪除媒體資料庫中的參照。
Additional Information
如果您需要進一步的協助或瞭解問題, 請聯絡支援人員。
Affected Products
NetWorkerArticle Properties
Article Number: 000222759
Article Type: Solution
Last Modified: 07 Mar 2024
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.