Облікові дані для підключення Hyper-V Data Manager

Summary: У цій статті бази знань описано вимоги до облікового запису для додавання джерела активів Hyper-V Server або Cluster у PowerProtect Data Manager.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Обліковому запису користувача домену Active Directory (AD) потрібно призначити такі дозволи, щоб запускати резервне копіювання та відновлення віртуальної машини Hyper-V (VM) під час додавання джерела ресурсів Hyper-V Server або Cluster за допомогою користувача домену:

Автономні:

  • Група локального адміністратора
  • Група адміністраторів Hyper-V
  • Віддалене керування користувачами
  • Користувачі віддаленого робочого столу

Кластер:

  • Група локального адміністратора
  • Група адміністраторів Hyper-V
  • Віддалене керування користувачами
  • Користувачі віддаленого робочого столу
  • Доступ для читання/запису кластера 
    Grant-clusteraccess -user <Domain\user> -Full

Незважаючи на надання дозволів, File Level Recovery (FLR) не вдається підключити резервну копію з такою помилкою:

2025-06-30T12:50:51.928Z ERROR [98d1d5f0658a4101;b774b4be3e4a26b8] - Exception occurred while handling flrAttach request: ADHP0002 
2025-06-30T12:50:51.928Z ERROR [98d1d5f0658a4101;b774b4be3e4a26b8] - Inner exception: Connecting to remote server hyperv-01 failed with the following error message : Access is denied. For more information, see the about_Remote_Troubleshooting Help topic. 
2025-06-30T12:50:51.941Z INFO [98d1d5f0658a4101;b774b4be3e4a26b8] - Pluginservice attach response: 
{
  "DiskControllers": null,
  "Status": "FAILURE",
  "Error": {
    "Code": 400,
    "ExtendedInfo": "",
    "Path": "",
    "Reason": "Attach operation cannot be completed because an Exception error occurred.",
    "Remediation": "To troubleshoot the issue:\n1) In the PowerProtect Data Manager UI, go to the Jobs window and click Export log and review the log file for more details.\n2) Retry the operation.\nIf the issue persists, contact Dell Customer Support.",
    "Timestamp": 638868882519312362,
    "MessageId": "ARHV0033",
    "MessageArgs": null,
    "MessageTemplate": null,
    "Message": "ADHP0002"
  }
} 

Cause

Обліковий запис, який використовувався для додавання формату Hyper-V, був <ім'ям> користувача без будь-якого префікса.

Під час FLR він додає ім'я апарата перед іменем користувача для підключення. Це призводить до використання локального облікового запису (hostname\username) замість доменного облікового запису (Domain\username).

Локальний обліковий запис не має потрібних дозволів.

Щоб перевірити, перевірте, чи можна виконати підключення winrm ззовні програми чи ні.

Використовуйте скрипт PowerShell, що містить команди, щоб виконати підключення winrm вручну.
Відредагуйте змінні скрипта, щоб додати деталі для сервера Hyper-V - FQDN /IP, резервне ім'я користувача та пароль.
Запустіть цей скрипт у PowerShell ISE на сервері Hyper-V (вузол-власник цільової віртуальної машини), для якого видно збій FLR.

Спробуйте скрипт, використовуючи повністю кваліфіковане доменне ім'я (FQDN), IP-адресу та коротке ім'я. Потім перевірте, з якою комбінацією працює з'єднання winrm для даного сервера Hyper-V. Спробуйте це для локального облікового запису та облікового запису домену,

Крім того, спробуйте ввести як ім'я користувача ntstyle, так і стиль User Entry Name (UPN) у поле імені користувача.
Ntstyle: домен\administrator
UPN: adminitrator@domain.com
 

Resolution

Для користувача домену облікові дані користувача мають бути в одному з таких форматів:

username@domain.comабо ntname\ім'я користувача

Змініть стиль користувача в облікових даних адміністратора інтерфейсу >> PowerProtect Data Manager

Additional Information

Зі сценарію PowerShell: 

$hostName="10.125.xx.xx" # example: "mywindowsvm.westus.cloudapp.azure.com ( IP /FQDN of the HYPERV server)"
$winrmPort = "5986"
$cred = New-Object System.Management.Automation.PSCredential("netbiosname\Username", (ConvertTo-SecureString 'Password123' -AsPlainText -Force))
# Connect to the machine
$sessionOptions = New-PSSessionOption -SkipCACheck -SkipCNCheck -SkipRevocationCheck
Enter-PSSession -ComputerName $hostName -Port $winrmPort -Credential $cred  -UseSSL -SessionOption


 

Article Properties
Article Number: 000359505
Article Type: Solution
Last Modified: 20 Jan 2026
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.