Dell Unity: le pianificazioni di larghezza di banda della replica non funzionano come previsto (correggibile dall'utente)

Summary: Questo articolo spiega perché le pianificazioni della larghezza di banda non vengono sincronizzate all'ora prevista quando il fuso orario è impostato su un fuso orario diverso da UTC.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

La sincronizzazione non si avvia all'ora prevista in cui è pianificata la larghezza di banda quando il fuso orario è impostato su un fuso orario diverso da UTC. Questo comportamento è segnalato in Dell Unity OE 5.2.

Cause

Quando la replica viene sospesa in base a una pianificazione, la sessione entra nel pool di sospensione. Ciò è causato da un problema nel codice in cui l'utilità di pianificazione utilizza l'ora UTC ignorando il fuso orario corrente.

Esempio:
la larghezza di banda viene sincronizzata tra le 09:00 di sabato e le 07:00 di lunedì, ora del Giappone (JST).

-------------------------------------------------[Pianificazione larghezza di banda]
Pianificazione fuso orario: UTC+9:00 (Tokyo)

-------------------------------------------------Lunedì - Venerdì
00:00 - 07:00 Larghezza di banda massima è 40,960 KB.
 07:00 - 24:00 La larghezza di banda massima è di 0 KB.
Sab - Dom
24:00 - 24:00 La larghezza di banda massima è di 40,960 KB.

-------------------------------------------------Il meccanismo è il seguente:
la sessione viene sospesa perché la larghezza di banda è impostata su 0 KB alle 07:00 ora JST del Giappone di lunedì.

La sessione sospesa viene posizionata nel pool di sospensione.

L'utilità di pianificazione controlla il pool di sospensione ogni ora per verificare se la sessione può essere trasferita.

Nel caso di questa pianificazione, la sessione è impostata per essere disponibile per il trasferimento da martedì 00:00 JST, ma quando si controlla il pool di sospensione, l'utilità di pianificazione tenta di avviare il trasferimento a martedì 00:00 UTC (09:00 AM JST) perché non tiene conto del fuso orario.

Tuttavia, dal momento che UTC 00:00-07:00 è JST 09:00-16:00 e la larghezza di banda 09:00-16:00 JST è impostata su 0 KB, il trasferimento non viene avviata.

L'operazione viene quindi ripetuta e, a partire da sabato 00:00 UTC (09:00 JST), la sincronizzazione inizia poiché la larghezza di banda è impostata su 40,960 KB.

In questo esempio, il problema si è verificato in JST. Tuttavia, il problema può verificarsi in altri fusi orari eccetto UTC.

Resolution

Risoluzione:
questo problema verrà risolto nella prossima versione di Unity OE.

Soluzione:
scegliere una delle due opzioni di soluzione alternativa:

  • Opzione 1 se è necessario disporre di 0 KB di larghezza di banda.
  • Opzione 2 se non si desidera modificare il fuso orario.

Opzione 1:
se si desidera utilizzare 0 KB, modificare il fuso orario in UTC e impostare la pianificazione.
 

AVVERTENZA: non utilizzare l'opzione 1 0 KB se si utilizza User Snap Replication.
Potrebbe verificarsi un riavvio irreversibile dell'SP. Da correggere in OE 5.3.


Opzione 2:
se il fuso orario non può essere modificato, anziché utilizzare un valore zero per la pianificazione della larghezza di banda, utilizzare un valore ridotto (ad esempio, 10 KB e così via) in modo che la sessione non venga posizionata nel pool di sospensione, evitando così il problema.

Affected Products

Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 500 , Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition ...

Products

Dell Unity Operating Environment (OE)
Article Properties
Article Number: 000204177
Article Type: Solution
Last Modified: 22 May 2023
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.