Dell Unity: Os agendamentos de largura de banda de replicação não estão funcionando conforme o esperado (corrigível pelo usuário)
Summary: Este artigo explica por que os agendamentos de largura de banda não são sincronizados no momento esperado quando o fuso horário é definido com algum fuso horário que não seja UTC.
Symptoms
Cause
Quando a replicação é pausada em um agendamento, a sessão entra no pool de suspensão. Isso é causado por um problema no código, em que o agendador usa o horário UTC ignorando o fuso horário atual.
Exemplo:
a largura de banda é sincronizada entre 09:00 de sábado e 07:00 de segunda-feira, horário do Japão (JST).
-------------------------------------------------
[Bandwidth Schedule]
Schedule time zone: UTC+9:00 (Tokyo)
-------------------------------------------------
Monday - Friday
00:00 - 07:00 Maximum Bandwidth is 40,960 KBs.
07:00 - 24:00 Maximum Bandwidth is 0 KBs.
Sat - Sun
24:00 - 24:00 Maximum Bandwidth is 40,960 KBs.
-------------------------------------------------
O mecanismo é o seguinte:
A sessão é suspensa porque a largura de banda é definida como 0 KB às 07:00 JST do Japão na segunda-feira.
A sessão suspensa é colocada no pool de suspensão.
O agendador verifica o pool de suspensão a cada hora para ver se a sessão pode ser transferida.
No caso desse agendamento, a sessão está definida como disponível para transferência a partir de 00:00 JST de terça-feira. Mas, ao verificar o pool de suspensão, o agendador tenta iniciar a transferência 00:00 UTC (09:00 JST) de terça-feira porque ele não considera o fuso horário.
No entanto, como 00:00 - 07:00 UTC é equivalente a 09:00 - 16:00 JST e a largura de banda para 09:00 - 16:00 JST está definida como 0 KB, a transferência não será iniciada.
Em seguida, a operação é repetida e, 00:00 UTC (09:00 JST) do sábado, a sincronização começa porque a largura de banda está definida como 40.960 KB.
Neste exemplo, o problema ocorreu no fuso horário JST. No entanto, o problema pode ocorrer em outros fusos horários, exceto UTC.
Resolution
Resolução:
Esse problema está programado para ser resolvido na próxima versão do Unity OE.
Solução temporária:
Escolha uma das duas opções de solução temporária:
- Opção 1: se você precisar ter 0 KB de largura de banda.
- Opção 2: se você não quiser alterar o fuso horário.
Opção 1:
Se você quiser usar 0 KB, altere o fuso horário para UTC e defina o agendamento.
Pode ocorrer uma reinicialização de pane da SP. O problema será corrigido no OE 5.3.
Opção 2:
Se o fuso horário não puder ser alterado, em vez de usar um valor zero para o agendamento de largura de banda, use um pequeno valor (por exemplo, 10 KB e assim por diante) para que a sessão não seja colocada no pool de suspensão, evitando assim o problema.