Dell Unity. Расписания пропускной способности репликации не работают должным образом (исправляется пользователем)

Summary: В этой статье объясняется, почему расписания пропускной способности не синхронизируются в запланированное время, если выбран любой часовой пояс, отличный от UTC.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Синхронизация не запускается в запланированное время по расписанию пропускной способности, если выбран любой часовой пояс, отличный от UTC. Это происходит в Dell Unity OE 5.2.

Cause

Когда репликация приостанавливается по расписанию, сеанс переходит в пул приостановки. Это вызвано ошибкой в коде, когда планировщик использует время UTC, игнорируя текущий часовой пояс.

Пример.
Пропускная способность синхронизируется в период с 09:00 субботы до 7:00 понедельника по японскому стандартному времени (JST).
----------------------------------------------
[Расписание для пропускной способности]
Часовой пояс расписания: UTC+9:00 (Токио)
-------------------------------------------------
С понедельника по пятницу
 с 00:00 до 07:00 максимальная пропускная способность составляет 40 960 Кбит/с.
 С 07:00 до 00:00 максимальная пропускная способность составляет 0 Кбит/с.
С субботы по воскресенье
 с 00:00 до 00:00 максимальная пропускная способность составляет 40 960 Кбит/с.
----------------------------------------------
Механизм представляет из себя следующее.
Сеанс приостанавливается, так как в 07:00 JST понедельника для пропускной способности установлено значение 0 Кбит/c.

Приостановленный сеанс помещается в пул приостановки.

Планировщик проверяет пул приостановки каждый час на возможность переноса этого сеанса.

Согласно этому расписанию, сеанс будет доступен для переноса с 00:00 UTC (09:00 JST) вторника, но при проверке пула приостановки планировщик пытается начать перенос во вторник в 00:00 UTC (09:00 JST), поскольку часовой пояс не учитывается.

Тем не менее, поскольку 00:00–07:00 UTC — это 09:00–16:00 JST, а пропускная способность в период с 09:00 до 16:00 JST установлена на 0 Кбит/с, передача не выполняется.

Затем операция повторяется, и в 00:00 UTC (09:00 JST) субботы начинается синхронизация, так как для пропускной способности установлено значение 40 960 Кбит/с.

В данном примере проблема возникла с японским стандартным временем (JST). Однако проблема может возникать и с другими часовыми поясами, за исключением UTC.

Resolution

Решение.
Планируется, что эта проблема будет устранена в следующем выпуске Unity OE.

Временное решение.
Выберите один из двух вариантов.

  • Вариант 1: если требуется пропускная способность 0 Кбит/с.
  • Вариант 2: если вы не хотите изменять часовой пояс.

Вариант 1.
Если требуется использовать значение 0 Кбит/с, измените часовой пояс на UTC и настройте расписание.
 

ПРЕДУПРЕЖДЕНИЕ. Не применяйте вариант 1 со значением 0 Кбит/с при использовании репликации пользовательских снимков.
Может привести к аварийной перезагрузке процессора СХД. Подлежит исправлению в OE 5.3.


Вариант 2.
Если часовой пояс не может быть изменен, вместо применения нулевого значения в расписании пропускной способности установите низкое значение (например, 10 Кбит/с и т. д.) во избежание перемещения сеанса в пул приостановки и возникновения проблемы.

Affected Products

Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 500 , Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition ...

Products

Dell Unity Operating Environment (OE)
Article Properties
Article Number: 000204177
Article Type: Solution
Last Modified: 22 May 2023
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.