InsightIQ "HTTP request timed out" of leeg bij het genereren van FSA-rapporten

Summary: De InsightIQ UI laadt een FSA-rapport (File System Analytics) niet geheel of gedeeltelijk als de time-out van de OneFS Application Programming Interface (API) te laag is.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

In InsightIQ 4.0 tot 4.2 en OneFS 8.0.x (of latere versies) verzamelt de OneFS RESTful API FSA-rapportdata. Als InsightIQ deze data niet kan verzamelen, wordt het FSA-rapport mogelijk niet, gedeeltelijk geladen of kunnen gebruikers niet door de directory's navigeren.

Cause

Het probleem doet zich voor wanneer de InsightIQ-server te snel een time-out vertoont voor de API-aanroep naar OneFS.

Om deze oorzaak te valideren, voert u de volgende opdracht uit (vervangen door CLUSTER_GUID met de juiste map):

      $ grep "HTTP request timed out" /var/log/insightiq_clusters/CLUSTER_GUID/api_connection.log

Uitvoer die lijkt op het onderstaande wordt weergegeven:

    2017-06-12 13:07:50,114,114 ERROR [api.py: 187] HTTP request timed out: https://172.22.33.27:8080/platform/3/fsa/results/4505/directories/4321902598
    2017-06-12 13:08:13,782,782 ERROR [api.py: 187] HTTP request timed out: https://172.22.33.27:8080/platform/3/fsa/results/4505/directories/4321902598

De gedefinieerde time-outwaarde wordt bekeken door deze opdracht uit te voeren:

$ grep 'read timeout=' /var/log/insightiq.log

De uitvoer ziet er als volgt uit. In dit voorbeeld is de time-out 20 seconden:

2018-04-12 04:18:30,203 WARNI [insightiq.lib.cluster.errors] APITimedOutError: HTTPSConnectionPool(host='10.104.6.138', port=8080): Read timed out. (read timeout=20) URI: https://10.104.6.138:8080/platform/3/statistics/history

Resolution

U kunt het probleem oplossen door de standaard time-out voor API-aanroepen naar OneFS te verhogen door het api.py Bestand.

Voer deze opdracht uit om de InsightIQ api.py Bestand:

    $ sudo vi /usr/share/isilon/lib/python2.7/site-packages/insightiq/lib/api_connection/api.py

On line 35, wijzigen TIMEOUT = 20 Aan TIMEOUT = 300.

Start vervolgens de InsightIQ-server opnieuw op:

    $ sudo service insightiq restart

Voor InsightIQ 4.2 is het pad /usr/share/isilon/lib/python3.10/site-packages/insightiq/lib/api_connection/api.py.

Affected Products

Isilon InsightIQ
Article Properties
Article Number: 000038614
Article Type: Solution
Last Modified: 20 Jan 2026
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.