Connectrix Brocade. Команды, возвращающие сообщение «No chassis permission for the user admin» при выполнении учетной записью администратора по умолчанию.

Summary: Почему некоторые команды возвращают сообщение «Нет разрешений на корпус для пользователя admin» при выполнении учетной записью администратора по умолчанию?

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

При выполнении некоторых команд уровня корпуса учетной записью администратора по умолчанию возвращается следующее сообщение:

sw0:FID128:admin> sshutil delknownhost -all
sshutil: No chassis permission for the user admin

Если создается вторая локальная учетная запись с правами администратора, эта же команда будет успешно выполнена для этого пользователя.

Cause

Из-за проблемы с внутренним файлом в FOS учетная запись администратора по умолчанию не может выполнять некоторые команды, что приводит к появлению сообщения «Нет разрешений корпуса для пользователя admin». Если в той же фабрике, что и затронутый коммутатор, есть другие коммутаторы, которые не демонстрируют такого поведения, на работающем коммутаторе можно выполнить команду распределения, чтобы передать настройки затронутому коммутатору.

Resolution

В следующем примере база данных паролей и политика конфигурации паролей отправляются на коммутатор с идентификатором домена 3.
 

#distribute -p PWD -d "3"


Если проблема затрагивает все коммутаторы в фабрике, необходимо обратиться в службу технической поддержки для создания сеанса ServiceShell, чтобы выполнить команду passwddefault на одном из затронутых коммутаторов.

После выполнения команду distribute можно выполнить на восстановленном коммутаторе, чтобы передать рабочую конфигурацию на другие коммутаторы в фабрике.

Affected Products

Connectrix B-Series
Article Properties
Article Number: 000228618
Article Type: Solution
Last Modified: 20 Sept 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.