Avamar – Isilon – Přírůstkové zálohování NDMP bylo dokončeno s výjimkami Error 9982

Summary: Protokol NDMP (Network Data Management Protocol) Přírůstkové zálohování NDMP dokončeno s výjimkami – chyba 9982

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Avamar – Isilon – Přírůstkové zálohy NDMP dokončeny s výjimkami.

V zálohách Avamar chybí během přírůstkových záloh soubory. Tento stav může způsobit, že data nebudou zálohována a nebudou k dispozici pro obnovení.

Během přírůstkového zálohování NDMP se systémem Isilon OneFS bylo zálohování dokončeno s výjimkami nebo selhalo s následující chybou Avtar:

 

 

avtar error: 2015-03-12 03:02:53 avtar Error <9982>: While processing _file_name_X or directory_name_X (inode XXXX713107), NDMP file history messages indicate the presence of a directory entry (inode:XXXX870544 name: Y) that doesn't appear in the data stream or in our previous backup of this directory.

 

  • Hodnocení závažnosti: Vysoký dopad
  • Popis: V zálohách Avamar chybí během přírůstkových záloh soubory, protože systém Isilon OneF nezjistil změny velikosti písmen v souborech a neodesílá datový tok pro soubory nebo adresáře se změnami velikosti písmen.

Cause

Hlavní příčina problému

Hlavní příčina problému souvisí s tím, jak skenování souborového systému provádí NAS a hledá změny, a ne klient NDMP. Je na NAS, aby určil, co se změnilo, a klient NDMP obdrží pouze to, co mu NAS sdělí, že se změnilo.

Software Avamar je během přírůstkového procesu citlivý a pokusí se najít předchozí datový proud ze file_name_X nebo directory_name_X, ale místo toho najde soubor nebo adresář directory_name_x File_Name_x a nevytvoří žádné platné zálohy.

Tento stav je způsoben tím, že systém Isilon OneFs nedetekuje změny velikosti písmen v souborech a neodesílá datový tok pro soubory nebo adresáře se změnami velikosti písmen.

Specifické chybové zprávy

Problém je spojen s následující chybou Avtar:

2015-03-12 03:02:53 avtar Error <9982>: While processing _file_name_X or directory_name_X (inode XXXX713107), NDMP file history messages indicate the presence of a directory entry (inode:XXXX870544 name: Y) that doesn't appear in the data stream or in our previous backup of this directory.
📋

Resolution

Trvalá oprava a její řešení

Oba týmy Avamar/Isilon pracují na konečném řešení, aby tento problém vyřešily od hlavní příčiny.

Trvalá oprava v systému Isilon OneFS v7.2.0.3, jak je uvedeno v části "Isilon OneFS Version 7.2.0.0 – 7.2.0.5 Release Notes" ID 147606.

V systému Isilon OneFS verze 7.1.1.5, jak je uvedeno v části "Isilon OneFS Version 7.1.1.0–7.1.1.8 Release Notes" ID 131843.
 

Možnosti zástupného řešení

  • 1. možnost: Provedení záloh úrovně 0
  • 2. možnost: Zákazníci budou mít přehled o přírůstkových zálohách, které byly dokončeny s výjimkami.


1. možnost: Proveďte zálohy úrovně 0.
               

  1. Některé chyby nebo výjimky musí zákazník sledovat, aby byla zachována integrita dat.
  2. Chcete-li předejít problémům s výkonem, rozdělte zálohu Isilon NDMP do několika cílových složek.
    Adresář "/ifs" by neměl být cílem. Pokud ano, použije se k zálohování všech dat pouze jeden datový proud.
     

2. možnost: Sledování přírůstkových záloh

Zkontrolujte protokoly, vyhledejte přejmenované soubory a poté se jich dotkněte, aby se při příštím přírůstkovém zálohování zobrazily změněné.

Nedovolte, aby se více než 30 po sobě jdoucích záloh "dokončilo s výjimkami", jinak je nutný další ruční zásah, aby software našel platný základ pro další přírůstkovou zálohu.

Čím déle je od poslední platné "úspěšné" zálohy, tím více dat odešle NAS během dalšího přírůstku.

 

VAROVÁNÍ: Při používání těchto alternativních řešení mějte na paměti potenciální problémy s výkonem a integritou dat.

Affected Products

Avamar

Products

Avamar, Avamar Plug-in for NDMP
Article Properties
Article Number: 000041743
Article Type: Solution
Last Modified: 27 Aug 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.