Avamar – Isilon – NDMP Inkrementelle Backups mit Ausnahmen abgeschlossen Fehler 9982
Summary: NDMP (Network Data Management Protocol) Inkrementelle NDMP-Backups mit Ausnahmen abgeschlossen – Fehler 9982
Symptoms
Avamar – Isilon – Inkrementelle NDMP-Backups mit Ausnahmen abgeschlossen.
Bei Avamar-Backups fehlen Dateien während inkrementeller Backups. Diese Bedingung kann dazu führen, dass Daten nicht gesichert werden und nicht für die Wiederherstellung verfügbar sind.
Während des inkrementellen NDMP-Backups mit Isilon OneFS wurde das Backup mit Ausnahmen abgeschlossen oder schlug mit dem folgenden Avtar-Fehler fehl:
avtar error: 2015-03-12 03:02:53 avtar Error <9982>: While processing _file_name_X or directory_name_X (inode XXXX713107), NDMP file history messages indicate the presence of a directory entry (inode:XXXX870544 name: Y) that doesn't appear in the data stream or in our previous backup of this directory.
- Bewertung des Schweregrads: Hohe Wirkung
- Beschreibung: Bei Avamar-Backups fehlen Dateien während inkrementeller Backups, da Isilon OneFs Änderungen der Groß-/Kleinschreibung nicht erkennt und keinen Datenstream für Dateien oder Verzeichnisse mit Groß-/Kleinschreibungsänderungen sendet.
Cause
Ursache des Problems
Die Hauptursache des Problems hängt damit zusammen, wie das Scannen von Dateisystemen vom NAS auf Änderungen durchgeführt wird, und nicht vom NDMP-Client. Es ist Sache des NAS zu bestimmen, was sich geändert hat, und der NDMP-Client erhält nur das, was der NAS mitteilt.
Avamar ist während des inkrementellen Prozesses sensibel und versucht, den vorherigen Datenstream aus dem "file_name_X oder directory_name_X" zu finden, findet aber stattdessen einen Datei- oder Verzeichnisänderungsfall "File_Name_x oder directory_name_x" und führt zu keinen gültigen Backups.
Diese Bedingung wird dadurch verursacht, dass Isilon OneFS keine Änderungen an der Groß-/Kleinschreibung erkennt und keinen Datenstream für Dateien oder Verzeichnisse mit Groß-/Kleinschreibungsänderungen sendet.
Spezifische Fehlermeldungen
Das Problem ist mit dem folgenden Avtar-Fehler verbunden:
2015-03-12 03:02:53 avtar Error <9982>: While processing _file_name_X or directory_name_X (inode XXXX713107), NDMP file history messages indicate the presence of a directory entry (inode:XXXX870544 name: Y) that doesn't appear in the data stream or in our previous backup of this directory. 📋
Resolution
Dauerhafte Lösung und Workarounds
Die endgültige Lösung wird von beiden Teams Avamar/Isilon durchgeführt, um dieses Problem an der Wurzel zu beheben.
Dauerhafte Fehlerbehebung in Isilon OneFS v7.2.0.3, wie in "Isilon OneFS Version 7.2.0.0 - 7.2.0.5 Versionshinweise" ID 147606 aufgeführt.
In Isilon OneFS v7.1.1.5, wie in "Isilon OneFS Version 7.1.1.0 - 7.1.1.8 – Versionshinweise" angegeben, ID 131843.
Optionen zur Problemumgehung
- Option 1: Durchführen von Level-0-Backups
- Option 2: Nachverfolgung inkrementeller Backups, die mit Ausnahmen abgeschlossen wurden
Option 1: Führen Sie Level-0-Backups durch.
- Einige Fehler oder Ausnahmen müssen vom Kunden nachverfolgt werden, um die Datenintegrität aufrechtzuerhalten.
- Um Performanceprobleme zu vermeiden, teilen Sie das Isilon-NDMP-Backup in mehrere Zielverzeichnisse auf.
Das Verzeichnis "/ifs" sollte kein Ziel sein. Wenn dies der Fall ist, wird nur ein einziger Stream verwendet, um alle Daten zu sichern.
Option 2: Nachverfolgen inkrementeller Backups
Überprüfen Sie die Protokolle, um die umbenannten Dateien zu finden, und bearbeiten Sie dann die Dateien, damit sie beim nächsten inkrementellen Backup geändert angezeigt werden.
Lassen Sie nicht mehr als 30 aufeinanderfolgende Backups "mit Ausnahmen abschließen", da andernfalls zusätzliche manuelle Intervention erforderlich ist, damit die Software eine gültige Basis für das nächste inkrementelle Backup findet.
Je länger seit dem letzten gültigen "erfolgreichen" Backup vergangen ist, desto mehr Daten werden vom NAS während des nächsten inkrementellen Backups gesendet.