PowerFlex: No se puede ejecutar el comando ScaleIO. Error: Comando fallido de MDM
Summary: No se puede ejecutar el comando ScaleIO, error: "Comando fallido de MDM. Estado: Sesión no válida: inicie sesión e inténtelo de nuevo".
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Cuando se intenta ejecutar un comando desde el administrador de metadatos primarios (MDM), los comandos de ScaleIO fallan con una sesión no válida:
# scli --mdm_ip --login --username admin Enter password: Logged in. User role is Administrator. System ID is XXXXXXXXX # scli --mdm_ip --query_all_volumes Error: MDM failed command. Status: Invalid session. Please login and try again.
Cause
El problema que hace que el MDM rechace las conexiones es que el usuario de CallHome "Monitor" vuelve a iniciar sesión cada diez minutos y no cierra la sesión. Esto hace que las sesiones de inicio de sesión de los usuarios se acumulen y llenen la tabla de sesiones antes de que el tiempo de espera agotado pueda expulsarlas.
Resolution
Elimine (o comente) las siguientes dos líneas en mdm/cfg/conf.txt, en ambos MDM:
user_session_hard_timeout_secs=86400 user_session_timeout_secs=28800 Stop CallHome service temporarily
/opt/emc/scaleio/callhome/bin/delete_service.sh
Reinicie el servicio de MDM:
kill
Espere 10 minutos y, a continuación, intente emitir scli después de iniciar sesión e iniciar el servicio Call Home nuevamente.
./opt/emc/scaleio/callhome/bin/create_service.sh
Additional Information
El error también puede ocurrir si se agota el tiempo de espera de la sesión de la CLI de ScaleIO.
Affected Products
PowerFlex SoftwareProducts
PowerFlex SoftwareArticle Properties
Article Number: 000065938
Article Type: Solution
Last Modified: 19 Sept 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.