Windows Server: Migrace Hyper-V za provozu může selhat v důsledku kontrolních bodů obnovy.

Summary: Tento článek obsahuje informace o chybách, ke kterým může dojít během migrace Hyper-V za provozu, pokud se k zálohování virtuálního počítače používá zálohovací software. Chyby jsou následující: „Virtual machine failed to generate VHD tree: 'Catastrophic failure'('0x8000FFFF').“ a „Virtual machine failed to generate VHD tree: 'The system cannot find the file specified.'('0x80070002').“ ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms


Shrnutí článku: Migrace technologie Hyper-V za provozu mezi hostiteli Hyper-V může selhat, pokud se pro virtuální počítače používají kontrolní body obnovy.


 

Problém:
 

Virtual machine failed to generate VHD tree: 'Catastrophic failure'('0x8000FFFF'). 

Virtual machine failed to generate VHD tree: 'The system cannot find the file specified.'('0x80070002').

 

Migrace za provozu se nezdaří a vyprší její časový limit. Protokol Hyper-V-VMMS umístěný v části „Applications and Services Logs\Microsoft\Windows“ v Prohlížeči událostí hlásí, že u zdroje vypršel časový limit migrace za provozu nebo se nezdařil. Pokus o odebrání kontrolních bodů obnovy pomocí prostředí PowerShell může vygenerovat jednu z následujících chyb.

Poznámka: Řešení zálohování technologie Hyper-V obecně používají k provádění záloh kontrolní body obnovení technologie Hyper-V. Software Avamar používá při zálohování kontrolní body obnovení.
Poznámka: Neodstraňujte následující položky ve snaze vyřešit příznaky popsané v tomto článku. “.C:\ProgramData\Microsoft\Windows\Hyper-V\Groups\groupregistry.vmcx“. Odstranění tohoto souboru může mít za následek, že problém nebude možné vyřešit. Obraťte se na technickou podporu na níže uvedených číslech.

Cause

Tento článek obsahuje informace o chybách, ke kterým může dojít během migrace Hyper-V za provozu, pokud se k zálohování virtuálního počítače používá zálohovací software. Chyby jsou následující: „Virtual machine failed to generate VHD tree: 'Catastrophic failure'('0x8000FFFF').“ a „Virtual machine failed to generate VHD tree: 'The system cannot find the file specified.'('0x80070002').“

Resolution

Řešení:


Zákazníci společnosti Dell se službami ProSupport nebo ProSupport Plus by se měli obrátit na technickou podporu společnosti Dell na čísle 800-456-3355 a požádat o pomoc. V opačném případě požádejte o pomoc technickou podporu Dell Avamar na čísle 800-782-4362.
 

Další informace:

 

Pokud virtuální počítač, který byl dříve migrován za provozu, již není spuštěn na původním zdrojovém uzlu, systému Windows se nepodaří odebrat kontrolní bod nebo skupinu vmgroup. Tento osamocený kontrolní bod nebo skupina vmgroup může způsobit selhání následných záloh Hyper-V. Může také zabránit migraci virtuálního počítače za provozu do jiných uzlů clusteru kvůli osamocené skupině vmgroup.

 

Před provedením postupů ručního čištění zkontrolujte následující adresu URL společnosti Microsoft níže. Článek znalostní databáze obsahuje řešení, která mohou řešit selhání migrace za provozu způsobená faktory prostředí:

 

https://learn.microsoft.com/en-us/troubleshoot/windows-server/virtualization/troubleshoot-live-migration-issuesTento hypertextový odkaz vás zavede na webové stránky mimo společnost Dell Technologies.


Identifikace typů kontrolních bodů Hyper-V

Následující dva příklady příkazů prostředí PowerShell vám pomůžou určit typ kontrolního bodu (označovaného také jako snapshoty).

Kontrolní bod virtuálního počítače v nástroji znázorněno Hyper-V Manager
Obrázek 1: Kontrolní bod virtuálního počítače v nástroji Hyper-V Manager


Standardní kontrolní bod: V tomto příkladu změňte název „TESTVM3“ pomocí názvu virtuálního počítače v prostředí zákazníka.

 Příkaz PowerShell používaný k identifikaci typu kontrolního bodu
Obrázek 2: Příkaz PowerShell používaný k identifikaci typu kontrolního bodu.


Kontrolní bod virtuálního počítače v nástroji znázorněno Hyper-V Manager
Obrázek 3: Kontrolní bod virtuálního počítače v nástroji Hyper-V Manager


Bod obnovy: V tomto příkladu nahraďte „MSCLOUD06“ názvem počítače, na kterém se virtuální počítač nachází v prostředí zákazníka. Nahraďte „TESTVM1“ názvem virtuálního počítače v prostředí zákazníka.

Příkaz PowerShell používaný k identifikaci typu kontrolního bodu
Obrázek 4: Příkaz PowerShell používaný k identifikaci typu kontrolního bodu.

 
 
 
 

Affected Products

Microsoft Windows Server 2016, Microsoft Windows Server 2019

Products

PowerEdge FC640, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440 , PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000134299
Article Type: Solution
Last Modified: 05 Feb 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.