Windows Server:回復チェックポイントの結果として、Hyper-V Live Migrationが失敗することがある

Summary: この記事では、バックアップ ソフトウェアを使用して仮想マシンのバックアップを実行するときに、Hyper-V Live Migration中に発生する可能性のあるエラーについて説明します。これらのエラーは、「Virtual machine failed to generate VHD tree: 'Catastrophic failure'('0x8000FFFF')」および「Virtual machine failed to generate VHD tree: 'The system cannot find the file specified.'('0x80070002').」です。 ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms


記事の概要:仮想マシンに回復チェックポイントが使用されている場合、Hyper-Vホスト間のHyper-V Live Migrationが失敗する可能性がある


 

トピック:
 

Virtual machine failed to generate VHD tree: 'Catastrophic failure'('0x8000FFFF'). 

Virtual machine failed to generate VHD tree: 'The system cannot find the file specified.'('0x80070002').

 

Live Migrationが失敗し、タイムアウトします。イベント ビューアーの[アプリケーションとサービス ログ]\Microsoft\WindowsにあるHyper-V-VMMSログは、Live Migrationがソースでタイムアウトまたは失敗したことを報告します。PowerShellを使用して回復チェックポイントを削除しようとすると、次のいずれかのエラーが生成される場合があります。

注:Hyper-Vバックアップ ソリューションは通常、Hyper-V回復チェックポイントを使用してバックアップを実行します。Avamarは、バックアップの実行時に回復チェックポイントを使用します。
注:この記事で説明されている現象を解決するために、次のファイルを削除しないでください。」C:\ProgramData\Microsoft\Windows\Hyper-V\Groups\groupregistry.vmcx」。このファイルを削除すると、この問題を解決できなくなる可能性があります。以下の番号で、Dellテクニカル サポートにお問い合わせください。

Cause

この記事では、バックアップ ソフトウェアを使用して仮想マシンのバックアップを実行するときに、Hyper-V Live Migration中に発生する可能性のあるエラーについて説明します。これらのエラーは、「Virtual machine failed to generate VHD tree: 'Catastrophic failure'('0x8000FFFF')」および「Virtual machine failed to generate VHD tree: 'The system cannot find the file specified.'('0x80070002').」です。

Resolution

解決方法:


ProSupportサービスまたはProSupport Plusサービスを利用しているDellのお客様は、800-456-3355でDellテクニカル サポートにお問い合わせください。それ以外の場合は、Dell Avamarテクニカル サポート(800-782-4362)にお問い合わせください。
 

その他の情報:

 

以前にLive Migrationを行ったVMが元のソース ノードで実行されていない場合、Windowsはチェックポイントまたはvmgroupの削除に失敗します。この孤立したチェックポイントまたはvmgroupにより、後続のHyper-Vバックアップが失敗する可能性があります。また、孤立したvmgroupが原因で、そのVMが別のクラスター ノードにLive Migrationを行えなくなる可能性もあります。

 

手動クリーンアップ手順を実行する前に、以下のMicrosoft URLを確認してください。次のKB記事では、環境要因によるLive Migrationの失敗に対処する可能性のあるソリューションについて説明します。

 

https://learn.microsoft.com/en-us/troubleshoot/windows-server/virtualization/troubleshoot-live-migration-issuesこのハイパーリンクをクリックすると、デル・テクノロジーズ以外のWebサイトにアクセスします。


Hyper-Vチェックポイント タイプの識別

次の2つのPowerShellコマンドの例は、チェックポイント(スナップショットとしても表示される)のタイプの判定に役立ちます。

Hyper-Vマネージャーで表示される仮想マシンのチェックポイント
図1:Hyper-Vマネージャーで表示される仮想マシンのチェックポイント


標準チェックポイント:この例では、「TESTVM3」をお客様の環境の仮想マシンの名前に置き換えます。

 チェックポイント タイプを識別するために使用されるPowerShellコマンド
図2:チェックポイント タイプの識別に使用するPowerShellコマンド
Hyper-Vマネージャーで表示される仮想マシンのチェックポイント


図3:Hyper-Vマネージャーで表示される仮想マシンのチェックポイント


回復チェックポイント:この例では、「MSCLOUD06」をお客様の環境で仮想マシンが存在するComputerNameに置き換えます。「TESTVM1」をお客様の環境での仮想マシンの名前に置き換えます。

チェックポイント タイプを識別するために使用されるPowerShellコマンド
図4:チェックポイント タイプを識別するために使用されるPowerShellコマンド

 
 
 
 

Affected Products

Microsoft Windows Server 2016, Microsoft Windows Server 2019

Products

PowerEdge FC640, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440 , PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000134299
Article Type: Solution
Last Modified: 05 Feb 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.