IDPA ACM zeigt keine DPC-Version an, Fehler: Verbindung zu Secure LDAP oder AD kann nicht hergestellt werden

Summary: ACM zeigt aufgrund eines AD-Fehlers keine Verbindung zu sicherem LDAP herzustellen oder keine Daten für die DPC-Version an.

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Symptoms

Einige Daten, wie z. B. die System Manager-Version, fehlen im ACM-Dashboard. 

Die ACM-server.log Datei weist den folgenden Fehler auf:

2019-08-30 10:53:25,045 ERROR [Thread-65867]-util.LDAPUtil: testConnection --> LDAP connection failed for Secure connection.javax.naming.CommunicationException: simple bind failed: xxx.xxx.xxx.xxx:636 [Root exception is javax.net.ssl.SSLHandshakeException: java.security.cert.CertificateException: No subject alternative names present]
2019-08-30 10:53:25,046 ERROR [Thread-65867]-dashboard.DataprotectionCentralDashboard: loadDataprotectionCentralDashboardResponse --> LDAP test connection failed:
com.emc.vcedpa.common.exception.ApplianceException: Unable to connect to secure LDAP/AD . Please verify whether the LDAP/AD Server provided is present as Alternate Name in LDAPS Certificate.
        at com.emc.vcedpa.common.util.LDAPUtil.testConnection(LDAPUtil.java:82)
        at com.emc.vcedpa.dashboard.DataprotectionCentralDashboard.loadDataprotectionCentralDashboardResponse(DataprotectionCentralDashboard.java:114)
        at com.emc.vcedpa.dashboard.DashboardResponse.loadDataprotectionCentralDashboardResponse(DashboardResponse.java:762)
        at com.emc.vcedpa.configure.DashboardInfoLoader$7.run(DashboardInfoLoader.java:156)
        at java.lang.Thread.run(Thread.java:748)

Cause

Der ACM-LDAP-Server ist nicht ordnungsgemäß konfiguriert, was dazu führt, dass die LDAP-Verbindung fehlschlägt.

Resolution

Dies ist ein Problem mit dem ldapconfig.xml -Datei auf dem ACM-Server. 

Die Spalte ldapconfig.xml hat die ACM-IP-Adresse für das LDAPHostName-Tag und nicht den ACM-FQDN. Die Verbindung versucht, den FQDN für den ACM zu verwenden, was dazu führt, dass die Verbindung zum LDAP-Server fehlschlägt.

Um dieses Problem zu beheben, bearbeiten Sie die folgende Datei mit vi:

/usr/local/dataprotection/var/configmgr/server_data/config/ldapconfig.xml

Ändern Sie das folgende Tag:

Hinweis: acmserver.domain.com muss durch den vollständig qualifizierten Domainnamen des tatsächlichen ACM-Servers ersetzt werden.
 
<ldapHostName>999.99.99.999</ldapHostName>
To 
<ldapHostName>acmserver.domain.com</ldapHostName>

Starten Sie den ACM-Server neu. 

Weitere Informationen erhalten Sie beim technischen Support von Dell.

Affected Products

PowerProtect Data Protection Software
Article Properties
Article Number: 000165559
Article Type: Solution
Last Modified: 25 Jun 2025
Version:  4
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