IDPA ACM n’affiche pas la version DPC, erreur : Impossible de se connecter à LDAP ou AD sécurisé

Summary: ACM n’affiche pas les données dans le tableau de bord pour la version DPC en raison d’une erreur Impossible de se connecter à LDAP sécurisé ou d’une erreur AD.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Certaines données, telles que la version de System Manager, sont manquantes dans le tableau de bord ACM. 

Le fichier server.log ACM présente l’erreur suivante :

2019-08-30 10:53:25,045 ERROR [Thread-65867]-util.LDAPUtil: testConnection --> LDAP connection failed for Secure connection.javax.naming.CommunicationException: simple bind failed: xxx.xxx.xxx.xxx:636 [Root exception is javax.net.ssl.SSLHandshakeException: java.security.cert.CertificateException: No subject alternative names present]
2019-08-30 10:53:25,046 ERROR [Thread-65867]-dashboard.DataprotectionCentralDashboard: loadDataprotectionCentralDashboardResponse --> LDAP test connection failed:
com.emc.vcedpa.common.exception.ApplianceException: Unable to connect to secure LDAP/AD . Please verify whether the LDAP/AD Server provided is present as Alternate Name in LDAPS Certificate.
        at com.emc.vcedpa.common.util.LDAPUtil.testConnection(LDAPUtil.java:82)
        at com.emc.vcedpa.dashboard.DataprotectionCentralDashboard.loadDataprotectionCentralDashboardResponse(DataprotectionCentralDashboard.java:114)
        at com.emc.vcedpa.dashboard.DashboardResponse.loadDataprotectionCentralDashboardResponse(DashboardResponse.java:762)
        at com.emc.vcedpa.configure.DashboardInfoLoader$7.run(DashboardInfoLoader.java:156)
        at java.lang.Thread.run(Thread.java:748)

Cause

Le serveur LDAP ACM n’est pas configuré correctement, ce qui entraîne l’échec de la connexion LDAP.

Resolution

Il s’agit d’un problème avec le ldapconfig.xml sur le serveur ACM. 

Le ldapconfig.xml possède l’adresse IP ACM pour la balise ldapHostName et non le FQDN ACM. La connexion tente d’utiliser le FQDN pour l’ACM et entraîne l’échec de la connexion au serveur LDAP.

Pour résoudre ce problème, modifiez le fichier suivant avec vi :

/usr/local/dataprotection/var/configmgr/server_data/config/ldapconfig.xml

Modifiez la balise suivante :

Remarque : acmserver.domain.com doit être remplacé par le FQDN du serveur ACM réel.
 
<ldapHostName>999.99.99.999</ldapHostName>
To 
<ldapHostName>acmserver.domain.com</ldapHostName>

Redémarrez le serveur ACM. 

Contactez le support Dell pour plus d’informations.

Affected Products

PowerProtect Data Protection Software
Article Properties
Article Number: 000165559
Article Type: Solution
Last Modified: 25 Jun 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.