NVP-vProxy: Workflows intermittently fail to run "SYSTEM error Unable to bind socket to port 0 from connection port range 0-0:"
Summary: NetWorker VMware Protection (NVP) backup workflows intermittently fail, reporting "unable to bind socket to port 0." This same type of error messaging appears for other workflows and processes on the NetWorker server. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The NetWorker VMware Protection (NVP) integration is configured with the vProxy Appliance.
The workflows intermittently fail to run in the environment with a socket bind error message.
The NetWorker Management Console (NMC) workflow messages and workflow log show:
MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow NSR notice Starting Protection Policy 'My_Policy' workflow 'My_WorkFlow'. MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow NSR notice Starting action 'My_Policy/My_WorkFlow/My_BackupAction' with command: 'nsrvproxy_save -s My_NSR_Name -j 1568619 -L incr -p My_Policy -w My_WorkFlow -A My_BackupAction'. MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow SYSTEM error Unable to bind socket to port 0 from connection port range 0-0: Cannot assign requested address MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow SYSTEM error Unable to bind socket to port 0 from connection port range 0-0: Cannot assign requested address MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow NSR notice Action 'My_Policy/My_WorkFlow/My_BackupAction's log will be in '/nsr/logs/policy/My_Policy/My_WorkFlow/My_BackupAction_1568635.raw'. MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow NSR notice Action 'My_Policy/My_WorkFlow/My_BackupAction' failed. MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow SYSTEM error Unable to bind socket to port 0 from connection port range 0-0: Cannot assign requested address MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow SYSTEM error Unable to bind socket to port 0 from connection port range 0-0: Cannot assign requested address MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow NSR notice Action 'My_Policy/My_WorkFlow/My_BackupAction log '/nsr/logs/policy/My_Policy/My_WorkFlow/My_BackupAction_1568635.raw' is empty. MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow NSR notice Workflow 'My_Policy/My_WorkFlow' failed.
The NetWorker daemon log shows similar bind socket error messages for other NetWorker processes in the environment.
Linux:
Windows:
/nsr/logs/daemon.raw
Windows:
[INSTALL_DRIVE]:\Program Files\EMC NetWorker\nsr\logs\daemon.raw
Cause
The NetWorker Server Operating System does not have any open sockets available for the NetWorker processes.
Resolution
See the NetWorker kernel parameter requirements and TCP buffers sections of the NetWorker Performance Optimization and Planning Guide: https://www.dell.com/support/product-details/product/networker/docs
Affected Products
NetWorkerProducts
NetWorker FamilyArticle Properties
Article Number: 000166369
Article Type: Solution
Last Modified: 25 Jul 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.