ViPR SRM: Błąd widoczny podczas uruchamiania programu mysql-database-check.sh
Summary: mysql-database-check-sh pokazuje, że operacja nie powiodła się
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Błąd widoczny po uruchomieniu mysql-database-check.sh
Błąd zaobserwowany:
Błąd zaobserwowany:
Error : Table apg.recovery_group doesn't exist Status : Operation failed
Cause
Tabela apg.recovery_group jest używana podczas sprawdzania bazy danych w celu odzyskania, nie jest to tabela konieczna i nie została utworzona podczas wykonywania zadania w tej chwili.
Resolution
Uruchom ponownie polecenie mysql-database-check-sh. Błąd zostanie usunięty, ponieważ tabela zostanie utworzona ponownie poprawnie podczas wykonywania zadania
Additional Information
Jak uruchomić sprawdzanie bazy danych:
Zaloguj się do każdego hosta zaplecza i uruchom następujące polecenie:
Alternatywnie możemy przeprowadzić kontrole, wykonując poniższe czynności:
Zaloguj się do głównego zaplecza:
Wprowadź bazę danych: [apg]
Wprowadź hasło: watch4net
Na drugorzędnych backendach zaloguj się jako root i wykonaj na każdej z baz danych pojedynczo, takich jak apg1, apg2, apg3 i apg4:
Wprowadź bazę danych: [APG1]
Wprowadź hasło: watch4net
Zaloguj się do każdego hosta zaplecza i uruchom następujące polecenie:
printf "apg\n--password=watch4net --all-databases\n" | /opt/APG/bin/mysql-database-check.sh
Alternatywnie możemy przeprowadzić kontrole, wykonując poniższe czynności:
Zaloguj się do głównego zaplecza:
srm:/opt/APG/bin # ./mysql-database-check.shWprowadź nazwę użytkownika: [apg]
Wprowadź bazę danych: [apg]
Wprowadź hasło: watch4net
Na drugorzędnych backendach zaloguj się jako root i wykonaj na każdej z baz danych pojedynczo, takich jak apg1, apg2, apg3 i apg4:
srm:/opt/APG/bin # ./mysql-database-check.shWprowadź nazwę użytkownika: [apg]
Wprowadź bazę danych: [APG1]
Wprowadź hasło: watch4net
Affected Products
SRMArticle Properties
Article Number: 000167710
Article Type: Solution
Last Modified: 20 Jun 2024
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.