SRDF/TimeFinder Manager: Chyba při použití příkazu STM IASPCTL REMOVEIOA obraz nebyl nalezen

Summary: Po použití příkazu STM IASPCTL REMOVEIOA na primárním/zdrojovém uzlu selžou všechny příkazy STM v bitové kopii IASP. To bylo pozorováno v sestaveních STM 9.1 a později v IBM 7.4. Funguje dobře na nižších verzích IBMi. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dochází k problému, kdy se uživatelům zobrazí chyba s IASPCTL (zdroj). Stejný příkaz funguje i s IASPCTLC

. Příkazy selhávají na uzlu SOURCE bez zjevného důvodu. 

Funguje to, když je příkaz IASPCTL STATUS spuštěn před procesem přepínače. Poté, co je iASP VARIED OFF a je proveden příkaz IASPCTL REMOVEIOA, stejný příkaz IASPCTL STATUS náhle selže s chybou "Image image-name not found"

V clusteru na našem testovacím S3TESTQ LPAR s názvem iASP "TESTQ" vykazuje stejné chování:    

Capture1.PNG

Příkaz STATUS selže, ale příkaz SRDFDRCTL selže se stejnou chybou. Příkaz IASPCTLC funguje pomocí příkazu CTLACTTGT k prohození rolí a poté spuštění příkazu status z cílového uzlu.

Cause

K tomuto problému dochází v systému IBMi V7R4 s STM 9.1 a novějším. Ve verzích 7.2 a 7.4 byly provedeny změny v některých rozhraních API IBM, které by mohly tento problém způsobovat. Tato rozhraní API se používají v Solutions Enabler a STM. Problém v současné době zkoumají společnosti Dell a IBM. Společnost IBM provedla změny v rozhraní API pro správu disků IBM, které je zodpovědné za provádění funkce REMOVEIOA. Změny byly provedeny tak, aby se zabránilo náhodnému uvedení částečných flashkopií do online režimu a přístupu k nim po ukončení flash disku.

Resolution

Zástupným řešením tohoto problému je vydávání příkazů ze záložních uzlů. 

Po příkazu REMOVEIOA lze zadávat příkazy z uzlu zotavení po havárii.

Chcete-li uvést primární uzel do správného stavu, je nutné vydat příkaz IASPCTLC ADDIOA ze záložního uzlu a na primárním uzlu spustit příkaz DISCOVER.
Article Properties
Article Number: 000183564
Article Type: Solution
Last Modified: 04 Mar 2021
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.