PowerEdge: Dispositivo de inicialização inacessível do Windows
Summary: O servidor gera o código de parada 0x7B: Dispositivo de inicialização inacessível.
Symptoms
O software antivírus ou de backup pode ter sido instalado, atualizado ou removido recentemente.
Cause
A causa mais provável para o erro "Dispositivo de inicialização inacessível", além de falha de hardware ou outro problema que impede o acesso à instalação do Windows, é um driver de filtro corrompido ou ausente.
Webroot, Acronis ArcServe, e os produtos StorageCraft são os infratores mais comuns.
Resolution
1. Inicialize a partir da mídia de instalação apropriada do Windows para entrar no WinRE.
2. Em "Instalar o Windows", selecione "Avançar" e clique em "Reparar seu computador".
3. Em "Opções de recuperação do sistema", selecione "Avançar" e clique em "Prompt de comando".
4. Execute "DiskPart" e, em seguida, "List Vol" - Anote a letra da unidade do volume do SO.
5. Execute "Exit" para sair do DiskPart.
Aviso: Se você não vir o volume do sistema operacional, execute "List Disk" - Se o armazenamento não estiver presente, você tem um problema de hardware ou o driver do controlador deve ser carregado (saia do DiskPart executando "Exit", copie o driver do controlador para a unidade USB, conecte-o ao servidor, execute "drvload PATH_TO_CONTROLLER_INF_FILE").
6. Navegue até o volume do SO executando "cd /d Z:\" ou "Z:".
Nota: Substituir "Z:\" OS volume's actual drive letter which was obtained by running "List Vol" from DiskPart.
7. Navegue até o diretório de configuração executando "cd Z:\Windows\System32\config".
8. Executar "mkdir Backup" então "copy SYSTEM Backup\SYSTEM" para fazer um backup do arquivo hive de registro do sistema.
9. Executar "reg load HKLM\Temp SYSTEM" para carregar o arquivo de seção de registro do sistema.
10 Executar "regedit" em seguida, navegue até "HKLM\Temp\ControlSet001\Control\Class".
11 Clique em "Editar", depois em "Localizar" ou pressione "CTRL+F" e procure "upperfilters".
12 Você está procurando drivers de filtro de terceiros que foram injetados no "UpperFilters" chave de registro de classes relacionadas ao armazenamento. Documente os nomes de quaisquer drivers de filtro externos ou inesperados e, em seguida, remova-os editando o UpperFilters chave do registro. Clique em "Find Next" ou pressione "F3" para continuar.
Padrão para DiskDrive Classe:
Padrão para SmartCardReader Classe:
Padrão para SmrDisk Classe:
Padrão para ScmDisk Classe:
Padrão para Volume Class:
13 Se você encontrou e removeu drivers de filtro de terceiros na etapa anterior, navegue até "HKLM\Temp\ControlSet001\Services" e, em seguida, procure o nome do driver do filtro. Documente o nome do serviço correspondente e defina seu "Start" chave de registro para "0" para desativá-lo. Clique em "Find next" ou pressione "F3" para verificar se não há referências encontradas.
Quatorze Feche o regedit e, em seguida, execute "reg unload HKLM\Temp" para descarregar o hive de registro do sistema.
15 Reinicialize o servidor.
Considerações adicionais:
Se drivers de filtro de terceiros estiverem causando a falha, aconselhe o cliente a desinstalar/reinstalar o software problemático.
Se drivers de filtro de terceiros não forem seus culpados, e o hardware tiver sido descartado, então ele está de volta ao básico.
16 Executar "bcdedit", verifique se há entradas para o gerenciador de inicialização e o carregador do Windows.
Exemplo de resultado:
Advertência: Se nada for devolvido por BCDEDIT um problema com os dados de configuração de inicialização (BCD), solucione o problema adequadamente. Uma solução potencial seria recriar o BCD executando "bootrec /rebuildbcd".
17 Executar "Dism /Image:Z:\ /Get-Packages", verifique se não há atualizações pendentes. Se houver atualizações pendentes, você pode revertê-las executando "Dism /Image:Z:\ /Cleanup-Image /RevertPendingActions" em seguida, reinicie.
18 Executar "Chkdsk Z:" para executar uma varredura somente leitura. Se a corrupção do NTFS for detectada, você poderá executar "Chkdsk /f /r Z:" para realizar um reparo. Chkdsk é potencialmente destrutivo, ou seja, pode causar perda de dados.
19 Executar "sfc /scannow /offbootdir=Z:\ /offwindir=Z:\Windows" para verificar/tentar reparar arquivos do sistema.
Vinte substitua os arquivos de hive do registro por backups do RegBack diretório:
Executar "cd Z:\Windows\System32\config".
Executar "ren DEFAULT DEFAULT.old".
Executar "ren SAM SAM.old".
Executar "ren SECURITY SECURITY.old."
" Executeren SOFTWARE SOFTWARE.old.
Executar "ren SYSTEM SYSTEM.old"Correr
"copy RegBack\DEFAULT DEFAULT".
Executar "copy RegBack\SAM SAM".
Executar "copy RegBack\SECURITY SECURITY".
Executar "copy RegBack\SOFTWARE SOFTWARE".
Executar "copy RegBack\SYSTEM SYSTEM".
21 Reinicialize o servidor.