PowerEdge: Dispositivo de inicialização inacessível do Windows

Summary: O servidor gera o código de parada 0x7B: Dispositivo de inicialização inacessível.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Após uma reinicialização ou falta de energia, o servidor gera o código de parada 0x7B: Dispositivo de inicialização inacessível. 

O software antivírus ou de backup pode ter sido instalado, atualizado ou removido recentemente.

Cause

A causa mais provável para o erro "Dispositivo de inicialização inacessível", além de falha de hardware ou outro problema que impede o acesso à instalação do Windows, é um driver de filtro corrompido ou ausente.

Webroot, Acronis ArcServe, e os produtos StorageCraft são os infratores mais comuns.

Resolution

1. Inicialize a partir da mídia de instalação apropriada do Windows para entrar no WinRE.
2. Em "Instalar o Windows", selecione "Avançar" e clique em "Reparar seu computador".
3. Em "Opções de recuperação do sistema", selecione "Avançar" e clique em "Prompt de comando".
4. Execute "DiskPart" e, em seguida, "List Vol" - Anote a letra da unidade do volume do SO.
5. Execute "Exit" para sair do DiskPart.

Aviso: Se você não vir o volume do sistema operacional, execute "List Disk" - Se o armazenamento não estiver presente, você tem um problema de hardware ou o driver do controlador deve ser carregado (saia do DiskPart executando "Exit", copie o driver do controlador para a unidade USB, conecte-o ao servidor, execute "drvload PATH_TO_CONTROLLER_INF_FILE").

6. Navegue até o volume do SO executando "cd /d Z:\" ou "Z:".
Nota: Substituir "Z:\" OS volume's actual drive letter which was obtained by running "List Vol" from DiskPart.
7. Navegue até o diretório de configuração executando "cd Z:\Windows\System32\config".
8. Executar "mkdir Backup" então "copy SYSTEM Backup\SYSTEM" para fazer um backup do arquivo hive de registro do sistema.
9. Executar "reg load HKLM\Temp SYSTEM" para carregar o arquivo de seção de registro do sistema.
10 Executar "regedit" em seguida, navegue até "HKLM\Temp\ControlSet001\Control\Class".
11 Clique em "Editar", depois em "Localizar" ou pressione "CTRL+F" e procure "upperfilters".

12 Você está procurando drivers de filtro de terceiros que foram injetados no "UpperFilters" chave de registro de classes relacionadas ao armazenamento. Documente os nomes de quaisquer drivers de filtro externos ou inesperados e, em seguida, remova-os editando o UpperFilters chave do registro. Clique em "Find Next" ou pressione "F3" para continuar.

Padrão para DiskDrive Classe:
editor do registro 
Padrão para SmartCardReader Classe:

editor do registro 

Padrão para SmrDisk Classe:
editor do registro 

Padrão para ScmDisk Classe:
editor do registro 

Padrão para Volume Class:
editor do registro 

13 Se você encontrou e removeu drivers de filtro de terceiros na etapa anterior, navegue até "HKLM\Temp\ControlSet001\Services" e, em seguida, procure o nome do driver do filtro. Documente o nome do serviço correspondente e defina seu "Start" chave de registro para "0" para desativá-lo. Clique em "Find next" ou pressione "F3" para verificar se não há referências encontradas.

Quatorze Feche o regedit e, em seguida, execute "reg unload HKLM\Temp" para descarregar o hive de registro do sistema.
15 Reinicialize o servidor.

Considerações adicionais:

Se drivers de filtro de terceiros estiverem causando a falha, aconselhe o cliente a desinstalar/reinstalar o software problemático.

Se drivers de filtro de terceiros não forem seus culpados, e o hardware tiver sido descartado, então ele está de volta ao básico.

16 Executar "bcdedit", verifique se há entradas para o gerenciador de inicialização e o carregador do Windows.
Exemplo de resultado:
saída do comando 

Advertência: Se nada for devolvido por BCDEDIT um problema com os dados de configuração de inicialização (BCD), solucione o problema adequadamente. Uma solução potencial seria recriar o BCD executando "bootrec /rebuildbcd".

17 Executar "Dism /Image:Z:\ /Get-Packages", verifique se não há atualizações pendentes. Se houver atualizações pendentes, você pode revertê-las executando "Dism /Image:Z:\ /Cleanup-Image /RevertPendingActions" em seguida, reinicie.

18 Executar "Chkdsk Z:" para executar uma varredura somente leitura. Se a corrupção do NTFS for detectada, você poderá executar "Chkdsk /f /r Z:" para realizar um reparo. Chkdsk é potencialmente destrutivo, ou seja, pode causar perda de dados. 

19 Executar "sfc /scannow /offbootdir=Z:\ /offwindir=Z:\Windows" para verificar/tentar reparar arquivos do sistema.

Vinte substitua os arquivos de hive do registro por backups do RegBack diretório:
Executar "cd Z:\Windows\System32\config".
Executar "ren DEFAULT DEFAULT.old".
Executar "ren SAM SAM.old".
Executar "ren SECURITY SECURITY.old."
" Executeren SOFTWARE SOFTWARE.old.
Executar "ren SYSTEM SYSTEM.old"Correr
"copy RegBack\DEFAULT DEFAULT".
Executar "copy RegBack\SAM SAM".
Executar "copy RegBack\SECURITY SECURITY".
Executar "copy RegBack\SOFTWARE SOFTWARE".
Executar "copy RegBack\SYSTEM SYSTEM".
21 Reinicialize o servidor.

Affected Products

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022, Microsoft Windows 2012 Server, Microsoft Windows 2012 Server R2, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350 , PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R470, PowerEdge R540, PowerEdge R550, PowerEdge R570, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R6715, PowerEdge R6725, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R7715, PowerEdge R7725, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T40, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000221200
Article Type: Solution
Last Modified: 02 Jun 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.