ECS : Impossible de générer la clé secrète pour l’utilisateur Swift si le nom d’utilisateur contient des lettres majuscules

Summary: Si un utilisateur Swift a été créé avant ECS 3.8.1.0 avec des caractères de casse mixtes et n’a pas été créé à l’aide de l’interface utilisateur, la génération d’une clé secrète pour cet utilisateur échoue. En outre, il permet à l’utilisateur de créer le même nom d’utilisateur avec toutes les lettres minuscules, car le nom d’utilisateur précédent a été enregistré avec des lettres mixtes. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Les erreurs ci-dessous s’affichent dans l’interface utilisateur :
  1. Erreur 2000 - Impossible de trouver l’entité dans l’URL de la demande. Impossible de trouver l’entité spécifiée dans l’URL avec l’ID donné TEST2.
  2. L’utilisateur voit deux utilisateurs Swift portant le même nom, mais diffèrent par la sensibilité à la casse.

Cause

Avant la version 3.8.1.0, l’API utilisateur Swift prenait en charge la création d’utilisateurs d’objets sensibles à la casse en raison d’un problème qui créait deux utilisateurs portant le même nom, mais de manière sensible à la casse. Exemple : « Dell » et « dell » deviennent deux utilisateurs uniques.

Il n’en va pas de même pour la création d’utilisateurs Swift via l’interface utilisateur. L’interface utilisateur convertit le nom d’utilisateur en minuscules avant d’appeler l’API. Cette génération de clé secrète pour ces deux utilisateurs correspond à la même clé secrète que le système convertit tous les utilisateurs en lettres minuscules avant de générer la clé secrète.

Resolution

S’il existe un utilisateur Swift avec une lettre mixte créée avant ECS 3.8.1.0, procédez comme suit pour résoudre le problème :
  1. Supprimez l’utilisateur Swift avec des lettres majuscules.
  2. Créez un nouvel utilisateur avec des lettres minuscules.

Affected Products

ECS, ECS Appliance
Article Properties
Article Number: 000223725
Article Type: Solution
Last Modified: 05 Apr 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.