Connectrix: MDB: Befehl "Nutzer anzeigen" zeigt ein falsches Datum und eine falsche Uhrzeit an 1. Januar 08:00 Nur

Summary: Der Befehl "Nutzer anzeigen" stellt Informationen zu Nutzern bereit, die beim System angemeldet sind. In diesem Artikel wird ein Problem erläutert, bei dem Datum und Uhrzeit falsch angezeigt werden. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Der Switch wird unter NX-OS 9.4.1a ausgeführt.

Die Ausgabe des Befehls users zeigt einen falschen Zeitstempel an, wie unten dargestellt:
[Model 9132T on NX-OS 9.4.1a]                    
===================
 
MDS9132T-s1fA-sw3# show version 
  system:    version 9.4(1a)                         <<<<<<<<<<<<<<<<<<< 9.4.1a
  system image file is:    bootflash:///m9100-s6ek9-mz.9.4.1a.bin
  system compile time:     12/25/2023 12:00:00 [01/12/2024 10:45:51]
  Reason: Reload due to non-disruptive system reload
 
MDS9132T-s1fA-sw3# sh clock
Time source is Hardware Calendar
09:55:11.833 IST Sat Jun 15 2024
 
MDS9132T-s1fA-sw3# show users
NAME     LINE         TIME         IDLE          PID COMMENT
admin    pts/0        Jan  1 05:30   .         16852 session=ssh *      <<<<<<<<<<<< Jan 1 05:30

Cause

Der Grund dafür ist eine Cisco-Fehler-ID-CSCWK43183, die NX-OS 9.4.1a betrifft.

Resolution

In NX-OS Version 9.4(1a) wird die Ausgabe des show users Der Befehl zeigt basierend auf der konfigurierten Zeitzone konsistent den 1. Januar zusammen mit dem Zeitversatz von UTC an.

Da die show users Ausgabe einen falschen Zeitstempel anzeigt, wird die show accounting log Kann auf den neuesten Anmeldezeitstempel für den Admin-Nutzer überprüft werden.

Problemumgehung:
When a user logs in to the switch on SSH, accounting log records the login of the user as below:
<timestamp> :type=start:id=10.138.65.80@pts/1:user=admin:cmd=
 
When a user logs into the switch on console, accounting log records the login of the user as below:
<timestamp> :type=start:id=console0:user=admin:cmd=
 
To view the last logged in time for a user named "admin", run the below command:
 # show accounting log | grep "start.*admin" | tail lines 1

Lösung:
Führen Sie ein Upgrade auf NX-OS 9.4.2 durch.
DS9132T-s1fA-sw3# show version | grep sys
  system:    version 9.4(2)                     <<<<<<<<<<<<<<<<<<<<< 9.4.2
  system image file is:    bootflash:///m9100-s6ek9-mz.9.4.2.bin
  system compile time:     4/25/2024 12:00:00 [05/10/2024 03:55:39]
 
MDS9132T-s1fA-sw3# sh users
NAME     LINE         TIME         IDLE          PID COMMENT
admin    pts/0        Jun 15 10:16   .          6362 (10.1xx.x5.1x5) session=ssh *   >>>> showing correct timings
 
After downgrading the switch from version 9.4.1a to 9.3.2a, the timestamps displayed by the 'show users' command are now correct.

BIOS compile time:       05/16/2023
  kickstart image file is: bootflash:///m9300-s1ek9-kickstart-mz.9.3.2a.bin   <<<<
  kickstart compile time:  4/25/2023 12:00:00 [05/13/2023 03:09:36]
  system image file is:    bootflash:///m9300-s1ek9-mz.9.3.2a.bin
  system compile time:     4/25/2023 12:00:00 [05/13/2023 04:28:40]
 
MDS9396S-s1fB-SW1# show users
NAME     LINE         TIME         IDLE          PID COMMENT
admin    pts/0        Jun 15 15:41   .          4855 (10.1xx.2xx.x8) session=ssh *  <<<< show users displaying the correct time.
 
MDS9396S-s1fB-SW1# show clock
Time source is NTP
15:42:36.016 ist Sat Jun 15 2024
 
Anmerkung:
Bevor Sie ein Upgrade auf 9.4.2 durchführen, überprüfen Sie, ob TACACS als Authentifizierungsprotokoll in Ihren Switches verwendet wird.
  • Wenn ja, kann ein Cisco-Defekt CSCWK14579 nach dem Upgrade auf 9.4.2 zu Authentifizierungsfehlern führen. Deaktivieren Sie daher TACACS und führen Sie das Firmwareupgrade durch. Aktivieren Sie dann die TACACS-Konfiguration.
  • Wenn Switches TACACS nicht für die Authentifizierung verwenden, können Sie problemlos ein Upgrade auf 9.4(2) durchführen.
Article Properties
Article Number: 000226156
Article Type: Solution
Last Modified: 19 May 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.