PowerFlex Performance Charts Not Displaying on Dashboard

Summary: The performance charts in PowerFlex Manager Platform (PFMP) do not show any data on the Dashboard.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The Dashboard has "NO DATA" reported and no performance statistics.

Dashboard showing NO DATA instead performance stats

 

Impact

Performance metrics are not visible on the Dashboard, which prevents administrators from monitoring and analyzing system performance in real-time.

Cause

The exact cause of the performance metrics not reporting on the Dashboard is unknown. Further investigation is required to determine the underlying issue.

See a similar issue in the following KB -  https://www.dell.com/support/kbdoc/000247159

Resolution

To resolve the issue, restart the powerflex-historical-metrics-collector pod:

kubectl delete pod -n powerflex $(kubectl get pods -n powerflex | grep historical | awk '{print $1}')

 

 

Below is an example of how the expected performance metrics should appear on the dashboard:

Expected performance metrics look

 

Impacted Version

PowerFlex 4.x

Fixed In Version

N/A Root cause not found.

Affected Products

PowerFlex rack RCM Software
Article Properties
Article Number: 000247171
Article Type: Solution
Last Modified: 10 Apr 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.