Linux roccioso: Errore "proprietà sconosciuta" durante il tentativo di modificare le proprietà dell'interfaccia di rete

Summary: Questo articolo fornisce informazioni sulla risoluzione dei problemi per l'errore "Impossibile salvare la connessione: connessione. Autoconnect-ports: proprietà sconosciuta" durante la modifica delle proprietà dell'interfaccia di rete. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Quando l'amministratore tenta di modificare le proprietà dell'interfaccia di rete utilizzando nmtui, viene visualizzato il seguente errore:

"Unable to save connection: connection.autoconnect-ports: unknown property"

Errore NMTUI

Di seguito è riportato un esempio degli errori osservati quando si tenta di configurare l'interfaccia utilizzando nmcli:

[root@localhost pcap]# nmcli connection modify BCM57414-IntNIC1-P1-25Gb 802-3-ethernet.mtu 1500
Warning: nmcli (1.46.0) and NetworkManager (1.44.0) versions don't match. Restarting NetworkManager is advised.
Error: Failed to modify connection 'BCM57414-IntNIC1-P1-25Gb': connection.autoconnect-ports: unknown property

[root@localhost pcap]# nmcli connection modify BCM57414-IntNIC1-P1-25Gb 802-3-ethernet.mtu 9000
Warning: nmcli (1.46.0) and NetworkManager (1.44.0) versions don't match. Restarting NetworkManager is advised.
Error: Failed to modify connection 'BCM57414-IntNIC1-P1-25Gb': connection.autoconnect-ports: unknown property

In questo esempio, l'amministratore ha tentato di modificare la MTU dell'interfaccia, ma lo stesso errore si verifica durante il tentativo di modificare un'altra proprietà.

Cause

La causa non è chiara. Per qualche motivo, Network Manager indica una mancata corrispondenza della versione.

Resolution

  1. Verificare all'indirizzo NetworkManager e nmcli Versioni: Verificare se l'opzione NetworkManager e nmcli Le versioni corrispondono. Nell'esempio riportato di seguito, le versioni corrispondevano:
    [root@localhost pcap]# rpm -qa | grep NetworkManager
    NetworkManager-libnm-1.46.0-4.el9_4.x86_64
    NetworkManager-1.46.0-4.el9_4.x86_64
    NetworkManager-wwan-1.46.0-4.el9_4.x86_64
    NetworkManager-team-1.46.0-4.el9_4.x86_64
    NetworkManager-wifi-1.46.0-4.el9_4.x86_64
    NetworkManager-bluetooth-1.46.0-4.el9_4.x86_64
    NetworkManager-adsl-1.46.0-4.el9_4.x86_64
    NetworkManager-tui-1.46.0-4.el9_4.x86_64
    NetworkManager-config-server-1.46.0-4.el9_4.noarch
  2. Riavvia NetworkManager: Riavvio di NetworkManager Il servizio può risolvere il problema:
    [root@localhost pcap]# systemctl restart NetworkManager
  3. Verificare le impostazioni: Dopo il riavvio, verificare che le impostazioni modificate siano state applicate correttamente:
    [root@localhost pcap]# nmcli connection show BCM57414-IntNIC1-P1-25Gb | grep 802-3-ethernet.mtu
    802-3-ethernet.mtu:                     9000
    [root@localhost pcap]# nmcli connection show BCM57414-IntNIC1-P2-25Gb | grep 802-3-ethernet.mtu
    802-3-ethernet.mtu:                     9000
  4. Abbassare e sollevare le porte per applicare la nuova configurazione:
    [root@localhost pcap]# nmcli con down BCM57414-IntNIC1-P1-25Gb && nmcli con up BCM57414-IntNIC1-P1-25Gb
    Connection 'BCM57414-IntNIC1-P1-25Gb' successfully deactivated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/2)
    Connection successfully activated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/17)
    
    [root@localhost pcap]# nmcli con down BCM57414-IntNIC1-P2-25Gb && nmcli con up BCM57414-IntNIC1-P2-25Gb
    Connection 'BCM57414-IntNIC1-P2-25Gb' successfully deactivated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/3)
    Connection successfully activated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/18)
  5. Testare la connettività: In questo esempio, l'amministratore ha modificato l'impostazione MTU ed ha eseguito un test ping per verificare la connettività e la corretta applicazione della MTU:
    [root@localhost pcap]# ping 192.168.15.10 -s8972 -c4
    PING 192.168.15.10 (192.168.15.10) 8972(9000) bytes of data.
    8980 bytes from 192.168.15.10: icmp_seq=1 ttl=64 time=0.287 ms
    8980 bytes from 192.168.15.10: icmp_seq=2 ttl=64 time=0.136 ms
    8980 bytes from 192.168.15.10: icmp_seq=3 ttl=64 time=0.125 ms
    8980 bytes from 192.168.15.10: icmp_seq=4 ttl=64 time=0.135 ms

Per informazioni più dettagliate sulla configurazione di rete, consultare la documentazione ufficiale di Rocky Linux: Configurazione di rete - DocumentazioneQuesto link ipertestuale indirizza a un sito web esterno a Dell Technologies.

Affected Products

Red Hat Enterprise Linux Version 7, Red Hat Enterprise Linux Version 9, Red Hat Enterprise Linux Version 8
Article Properties
Article Number: 000284281
Article Type: Solution
Last Modified: 08 Nov 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.