NVP vProxy : Les sauvegardes cohérentes avec les applications SQL Server 2022 ne démarrent pas

Summary: Une machine virtuelle SQL Windows est configurée pour les sauvegardes cohérentes avec les applications à l’aide de NetWorker VMware Protection (NVP) MSVMAPPAGENT. La sauvegarde ne démarre pas et aucun message n’apparaît dans les journaux. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • La solution NetWorker VMware Protection (NVP) est configurée pour protéger une machine virtuelle (VM) Windows Server 2022.
  • La machine virtuelle contient SQL Server 2022.
  • L’option App Consistency est activée dans le workflow configuré pour protéger la machine virtuelle, ce qui permet d’effectuer une sauvegarde MSVMAPPAGENT (cohérente avec SQL) de la machine virtuelle.
  • Après le démarrage du workflow de sauvegarde, aucune session de sauvegarde n’est établie pour la machine virtuelle SQL. Aucun snapshot de machine virtuelle n’est créé dans VMware.
  • Il n’y a aucune erreur dans le journal de la session de sauvegarde de la machine virtuelle ou dans « C :\Program Files\DPSAPPS\MSVMAPPAGENT\logs » sur la machine virtuelle. Le dossier MSVMAPPAGENT n’est peut-être même pas créé sur la machine virtuelle.
  • Les sauvegardes d’image standard (non cohérentes avec les applications) réussissent pour la même machine virtuelle.

Cause

App Consistent pour SQL Server 2022 n’est pas pris en charge par la solution vProxy. Reportez-vous à la note 58266 de la matrice de compatibilité NetWorker : https://elabnavigator.dell.com/eln/modernHomeAutomatedTiles?page=NetWorker

Resolution

Remarque : Consultez la matrice de compatibilité NetWorker pour connaître les modifications apportées à la prise en charge de Windows+SQL Server 2022.

Pour effectuer des sauvegardes SQL sur la machine virtuelle, installez le client NetWorker et les logiciels NetWorker Module for Microsoft .

|Les packages d’installation et la documentation de NetWorker Client sont disponibles sur la page des produits NetWorker :
https://www.dell.com/support/product-details/product/networker/drivers

Les packages d’installation et la documentation de NetWorker Module for Microsoft sont disponibles via :
https://www.dell.com/support/product-details/product/networker-module-for-microsoft/overview

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000291158
Article Type: Solution
Last Modified: 05 Mar 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.