PowerFlex: SDC "perdió el acceso al volumen"

Summary: El SDC de PowerFlex puede registrar "acceso perdido al volumen" cuando el almacén de datos local de SVM no puede responder en un momento determinado.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

 

  • En el host ESXi de la SVM problemática, el controlador de la controladora RAID informa lsi_mr3 anulaciones en el disco subyacente del almacén de datos local y ESXi informa la pérdida de acceso al volumen.

En el registro de VMkernel:

2017-12-03T17:47:01.634Z cpu54:33648)ScsiDeviceIO: 2636: Cmd(0x43be59ec8a00) 0x1a, CmdSN 0x1f6f4 from world 0 to dev "naa.6800733259adcc4f214574350619b91a" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x24 0x0.
2017-12-03T17:47:44.125Z cpu1:171607)lsi_mr3: mfi_TaskMgmt:254: Processing taskMgmt abort for device: vmhba2:C2:T0:L0
2017-12-03T17:47:44.125Z cpu1:171607)lsi_mr3: mfi_TaskMgmt:262: ABORT
2017-12-03T17:47:45.125Z cpu34:32905)lsi_mr3: mfi_TaskMgmt:254: Processing taskMgmt virt reset for device: vmhba2:C2:T0:L0
2017-12-03T17:47:45.125Z cpu34:32905)lsi_mr3: mfi_TaskMgmt:258: VIRT_RESET cmd # 273733296
2017-12-03T17:47:45.125Z cpu34:32905)lsi_mr3: mfi_TaskMgmt:262: ABORT
2017-12-03T17:47:45.126Z cpu1:171607)lsi_mr3: fusionWaitForOutstanding:2531: megasas: [ 0]waiting for 1 commands to complete
2017-12-03T17:47:46.877Z cpu29:35817)HBX: 2851: 'datastore3': HB at offset 3691008 - Waiting for timed out HB:

En el registro de hostd:
2017-12-03T17:47:45.126Z info hostd[41B40B70] [Originator@6876 sub=Vimsvc.ha-eventmgr] Event 219 : Lost access to volume 59b2c23a-98396dd8-aa53-84a9c4b71ca1 (datastore3) due to connectivity issues. Recovery attempt is in progress and outcome will be reported shortly.

  • El dispositivo SDS puede informar la anulación de la tarea (que se puede encontrar tanto en var/log/messages como en el registro de VMware), por lo que el proceso de SDS en esta SVM experimentaría I/O prolongadas en tránsito, lo que afecta aún más la estabilidad del sistema ScaleIO

 

  • Luego, los SDC registran un error de I/O en el registro de VMkernel, ya que el SDS problemático estaba experimentando algunos problemas de conector de red debido a la respuesta lenta del almacén de datos local, y los almacenes de datos de aplicaciones que residen en el volumen de ScaleIO pueden informar la pérdida de acceso:
En el registro de VMkernel:
2017-12-03T17:47:52.060Z cpu39:33682)scini: netSock_RcvIntrn:1903: ScaleIO R2_0:Error: Failed Success to receive 128 data PTR 0x4306d2923de4 socket 0x4306d2924200
2017-12-03T17:47:54.061Z cpu1:33476)scini: mapVolIO_ReportIOErrorIfNeeded:361: ScaleIO R2_0:[201590843] IO-ERROR comb: 32ba80000015. offsetInComb 11387944. SizeInLB 1. SDS_ID de31ad4800000001. Comb Gen 39. Head Gen 10199.
2017-12-03T17:47:54.061Z cpu1:33476)scini: mapVolIO_ReportIOErrorIfNeeded:374: ScaleIO R2_0:Vol ID 0x756be73300000017. Last fault Status IO_HARD_ERROR(20).Last error Status NOT_CONN(4) Reason (ABORTED) Retry count (2) chan (4)

En el registro de hostd:
2017-12-03T17:47:54.125Z info hostd[3FAAFB70] [Originator@6876 sub=Vimsvc.ha-eventmgr] Event 220 : Lost access to volume 59cb2f80-40ad26ac-cf4f-84a9c4b71ce1 (OS_windows_01) due to connectivity issues. Recovery attempt is in progress and outcome will be reported shortly.
2017-12-03T17:47:54.125Z info hostd[3FAAFB70] [Originator@6876 sub=Vimsvc.ha-eventmgr] Event 221 : Lost access to volume 59cb2f9e-984e3ff8-63e1-84a9c4b71ce1 (OS_Linux_01) due to connectivity issues. Recovery attempt is in progress and outcome will be reported shortly.
Impact

 

Impacto

Es posible que SDC pierda acceso a almacenes de datos que residan en el volumen de PowerFlex y que la aplicación o la VM en esos almacenes de datos se vean afectadas; por ejemplo, el sistema de archivos pasó a ser de solo lectura.
 

Cause

  • Los almacenes de datos VMFS se monitorean a través de los latidos que se emiten en forma de operaciones de escritura aproximadamente una vez cada 3 s en los volúmenes VMFS desde los hosts. Cuando el almacén de datos local de SVM responde lentamente, el tiempo total de I/O de latido no se completa en una ventana de 16 segundos, el almacén de datos se marca como offline y hostd genera un mensaje de pérdida de acceso al registro de volumen para reflejar este comportamiento. Puede encontrar más detalles en la base de conocimientos de VMware Comprensión del acceso perdido a los mensajes de volumen en ESXi 
  • En este caso, no se puede predecir el comportamiento exacto del SDS, como en qué se perderían los mensajes keepalive, contra qué otros componentes de PowerFlex. Algunas de las I/O de SDC que este SDS debe atender, pueden superar el tiempo de espera del sistema operativo o de las aplicaciones, lo que causa un impacto.

Resolution

Comuníquese con VMware y el proveedor de hardware para solucionar el problema de la controladora RAID o de su firmware y controlador.

Additional Information

Una solución alternativa temporal sería quitar el SDS con problemas o migrarlo a otro almacén de datos local en buen estado.

Affected Products

PowerFlex appliance Intelligent Catalog Software, VxFlex Product Family

Products

PowerFlex rack, VxFlex Ready Nodes, PowerFlex Appliance, PowerFlex custom node, PowerFlex appliance R650, PowerFlex appliance R6525, PowerFlex appliance R660, PowerFlex appliance R6625, Powerflex appliance R750, PowerFlex appliance R760 , PowerFlex appliance R7625, PowerFlex custom node, PowerFlex custom node R650, PowerFlex custom node R6525, PowerFlex custom node R660, PowerFlex custom node R6625, PowerFlex custom node R750, PowerFlex custom node R760, PowerFlex custom node R7625, PowerFlex rack connectivity, PowerFlex rack HW, PowerFlex rack RCM Software, VxFlex Product Family, VxFlex Ready Node, VxFlex Ready Node R640, VxFlex Ready Node R740xd, PowerFlex appliance R640, PowerFlex appliance R740XD, PowerFlex appliance R7525, PowerFlex appliance R840, VxFlex Ready Node R840 ...
Article Properties
Article Number: 000027267
Article Type: Solution
Last Modified: 22 Sep 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.