Microsoft App Agent - Determinare se è necessario il riavvio

Summary: L'articolo della KB consente di determinare se l'aggiornamento o la rimozione di Microsoft App Agent richiederà un riavvio. Ciò si verifica in genere quando è abilitata l'opzione Table Level Recovery con Itempoint. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

La disinstallazione o l'aggiornamento di Microsoft App Agent con ripristino a livello di tabella richiede il riavvio.

 

Cause

A causa dei driver specifici installati con il ripristino a livello di tabella con Microsoft App Agent, potrebbe essere necessario riavviare il sistema.

 

Resolution

Eseguire un PowerShell con privilegi elevati ed eseguire il comando seguente, che restituisce valori specifici in base al fatto che ItemPoint sia installato o meno: è molto probabile che il server richieda un riavvio se disinstallato o durante l'aggiornamento.
(Get-ItemProperty -Path 'HKLM:\SOFTWARE\EMC\DDBMSS' -ErrorAction SilentlyContinue).PSObject.Properties.Name -contains 'ItemPointEnabled'

Esempio:

PS C:\Users\administrator.AMER> (Get-ItemProperty -Path 'HKLM:\SOFTWARE\EMC\DDBMSS' -ErrorAction SilentlyContinue).PSObject.Properties.Name -contains 'ItemPointEnabled'
False
PS C:\Users\administrator.AMER> (Get-ItemProperty -Path 'HKLM:\SOFTWARE\EMC\DDBMSS' -ErrorAction SilentlyContinue).PSObject.Properties.Name -contains 'ItemPointEnabled'
True

In sintesi, eseguire una query nel Registro di sistema per quel valore all'interno del percorso e, se esiste, dice True, altrimenti false -.

False = Idealmente nessun riavvio: il sistema operativo può comunque richiedere il riavvio, ma non è basato sull'agent**.
True = molto probabilmente è richiesto il riavvio.

 

Additional Information

Registro di sistema di Windows DDBMS

Products

Microsoft App Agent, PowerProtect App Direct
Article Properties
Article Number: 000375390
Article Type: Solution
Last Modified: 15 Oct 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.