Data Domain - Cannot Recover from NVRAM: Recently Written Data May be Lost
Summary: This article explains how to resolve an issue that causes the Autosupport (ASUP) alert:"Cannot recover from NVRAM: Recently written data may be lost". Symptoms ASUP Alert: Cannot recover from NVRAM: Recently written data may be lost Replication disabled System keeps rebooting System fails to complete boot process Kernel panic ...
Symptoms
Cannot Recover from NVRAM: Recently Written Data May be Lost
PURPOSE
This article explains how to resolve an issue that causes the Autosupport (ASUP) alert: "Cannot recover from NVRAM: Recently written data may be lost".
Symptoms
- ASUP Alert: Cannot recover from NVRAM: Recently written data may be lost
- Replication disabled
- System keeps rebooting
- System fails to complete boot process
- Kernel panic
APPLIES TO
- All Data Domain systems
- All Software Releases
Cause
CAUSE
- NVRAM not properly transferred during chassis swap
- NVRAM batteries discharged
- NVRAM card defective
- Stale NVRAM contents
Resolution
SOLUTION
This alert is triggered when the NVRAM batteries are discharged causing the data on the NVRAM card to be lost.
If this alert is received after a chassis swap, ensure that the NVRAM card was moved from the old chassis to the new chassis as directed in the FRU document, unless specifically noted otherwise by Data Domain Support.
Battery Charging Procedure
- If the system has been offline for a period of time, the NVRAM batteries may have discharged causing this alert. To resolve this condition follow the NVRAM charging procedure 181393 .
- If the alert persists, all replication contexts on the source system and any related contexts on the destination systems will need to be broken and reestablished 180668 .
A new NVRAM card is needed if:
- The NVRAM batteries do not charge completely when following the NVRAM battery charging procedure (Charging NVRAM Batteries 181393 ).
- The system has been running for more than a week with NVRAM batteries fully charged and one or both of the NVRAM batteries is losing charge.
- The LEDs indicate a replacement is needed according to the following table:
Table 1: NVRAM LED Behavior
|
LED Function |
Function Description |
Action Recommended |
DD120/ 4xx/5xx |
DD660/ 690g |
DD140 / 610/630 DD880/g |
|
Power LED |
Green solid: Input power to NVRAM card is valid |
Normal - No action indicated |
X |
X |
X |
|
OFF: No input power to NVRAM card or on-board FPGA is failing |
If other system LEDs are functioning correctly, and/or FAULT LED is solid amber, then replace the card. |
|
|
|
|
|
Fault LED |
Amber blinking: batteries are charging |
If the system has been powered off, follow the KB article instructions regarding battery charging. |
X |
X |
X |
|
Amber solid: card has a fault |
Replace the NVRAM card |
X |
X |
X |
|
|
OFF: batteries are charged and card has no fault |
No action needed |
X |
X |
X |
|
|
Test Button |
PUSH this button to test the internal logic and all LEDs (system must be powered ON for this test) |
All 3 LEDs should illuminate when button is pressed. If any LED does not illuminate, the card may be bad - replace it. |
X |
X |
n/a |
|
Remove LED |
OFF: Normal. Should always be OFF except when performing TEST LED function |
Not applicable |
X |
X |
n/a |
|
Blue solid: illuminated when TEST LED button is pressed |
None |
X |
X |
To replace the NVRAM card, contact your contracted support provider to arrange for a replacement.
REFERENCE
Additional Information