Avamar: VMware-Image-Wiederherstellung fehlgeschlagen "Timeout beim Warten auf erzeugte Wiederherstellungsmetadaten"
Summary: VMware-Image-Wiederherstellungen schlugen fehl mit "Timeout on wait for spawned restore metadata avtar process to complete".
Symptoms
VMware-Image-Wiederherstellungen auf einer neuen virtuellen Maschine oder Image-Wiederherstellungen auf einer neuen Festplatte schlagen mit dem folgenden Fehler fehl:
avvcbimage Error <0000>: [IMG0011] Timeout on wait for spawned restore metadata avtar process to complete
Bei der Wiederherstellung auf einer neuen VM oder Festplatte muss der normale Wiederherstellungsworkflow eine "Mini-Wiederherstellung" der VM-Konfigurationsdateien aus dem vom Nutzer ausgewählten Backup durchführen. Diese Dateien werden als .vmx- und .vmdk-Deskriptordateien bezeichnet.
Sobald die Daten wiederhergestellt sind, erstellt der Proxy aus der wiederhergestellten VM-Konfiguration ein neues virtuelles VM-Laufwerk. Anschließend kann mit der Image-Wiederherstellung des virtuellen Laufwerks fortgefahren werden. Der Mini-Wiederherstellungsjob, der als "Metadatenwiederherstellung" bezeichnet wird, hat ein Standard-Timeout von 5 Minuten. Da die VMX-Wiederherstellung klein ist (in der Regel ~15 KB), sollte die Wiederherstellung nur wenige Sekunden dauern.
Wenn dieses Verhalten jedoch im Wiederherstellungsprotokoll auftritt, wird Folgendes angezeigt:
1. 2017-04-14 12:50:21 avvcbimage Info : Process 4486 (/usr/local/avamarclient/bin/avtar) for workorder MOD-1492174248297#99 started
2. 2017-04-14 12:55:21 avvcbimage Error : [IMG0011] Timeout on wait for spawned restore metadata avtar process to complete
3. 2017-04-14 12:59:51 avvcbimage Info : Process 4486 (/usr/local/avamarclient/bin/avtar) finished (code 0: success)
Die Protokollmeldungen zeigen, dass die benötigte Gesamtzeit 9 Minuten und 30 Sekunden betrug, aber schließlich war die Metadatenwiederherstellung erfolgreich. Die Image-Wiederherstellungsaufgabe ist jedoch fehlgeschlagen, da die standardmäßige Unterprozesszeit von 5 Minuten oder 300 Sekunden überschritten wurde.
Cause
Die Data Domain wird mit einer Schnittstellengruppe (ifgroup) konfiguriert, die den ddboost-Client (avtar) anweist, eine Verbindung zu einer Schnittstelle herzustellen. Diese Schnittstelle wird blockiert zwischen Client (Proxy)
Überprüfen Sie in der Data Domain-Befehlszeile oder auf Webseite die dd-Einstellungen.
Beispieleinstellungen:
sysadmin@ddve# Ifgroup Show Config Group-name Status Interfaces ---------- ------- ---------- default enabled 192.168.69.80 ---------- ------- ---------- sysadmin@ddve net show config ethV0 Link encap:Ethernet HWaddr 00:50:56:98:A6:66 inet addr:10.240.196.80 Bcast:10.240.196.255 Mask:255.255.255.0 ethV1 Link encap:Ethernet HWaddr 00:50:56:98:56:8F inet addr:192.168.69.80 Bcast:192.168.69.255 Mask:255.255.255.0 In the example above the default Ifgroup setting will cause the client to initially connect to primary/management interface of 10.240.196.80 but will see the ifgroup settings and try to connect with 192.168.69.80. RPC has a default time-out value of 180 seconds but the client will try multiple times (3 in this case) which would add up to a total of 540 seconds or 9.5 mins. After trying three times the connection will fallback to 10.240.196.80 but by this time the image restore job would have timed out. From the proxy run this series of commands to confirm the issue replacing the IP addresses as appropriate:
rpcinfo -p 192.168.69.80 (command stops responding for 3 min)rpcinfo -p <data domain fully qualified hostname>rpcinfo -p 10.120.24.49
Resolution
Lösung:
Öffnen Sie die Verbindung zwischen Client- und Data Domain-ifgroup-Schnittstellen.
Eine weitere Option ist das Deaktivieren der ifgroup.
Alternative Problemumgehung:
Erhöhen Sie den Timeout-Wert für den Unterprozess, z. B. auf 10 Minuten (600 s). Dadurch kann die Wiederherstellung abgeschlossen werden.
Fügen Sie dazu einen Parameter hinzu --subprocesstimeoutsecs=600 zum avvcbimageAll.cmd Datei, die sich im Verzeichnis /usr/local/avamarclient/var/ Auf dem Proxy
Weitere Informationen zum Bearbeiten der avvcmimage.cmd Datei finden Sie unter
Additional Information
Zugehöriger Artikel: Avamar – Die VMware-Image-Wiederherstellung ist mit dem FATALEN Fehler "GetDiskLogged Failed" fehlgeschlagen (möglicherweise ist eine Anmeldung beim Dell Support erforderlich)