Avamar: Roskien keräys epäonnistuu MSG_ERR_TRYAGAINLATER

Summary: Jos varmuuskopioinnit ovat sallittuja roskankeräyksen ylläpitotyön aikana, v7.x-versiosta alkaen näyttöön saattaa joskus tulla MSG_ERR_TRYAGAINLATER-viesti.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Avamar Garbage Collection -palvelun ylläpitotyö päättyy virheeseen MSG_ERR_TRYAGAINLATER.

 

Voit vahvistaa ongelman seuraavasti:

  1. status.dpn Osoittaa:

admin@avamarhost:~/>: status.dpn
...
Last GC: finished Mon Dec 23 06:08:00 2013 after 03m 05s >> recovered 0.00 KB (MSG_ERR_TRYAGAINLATER)

 

  1. Vahvista käyttämällä dumpmaintlogs Komento:

admin@avamarhost:~/>: dumpmaintlogs --types=gc --days=1
...
2013/12/23-12:08:00.9673 {0.0} <4202> failed garbage collection with error MSG_ERR_TRYAGAINLATER

 

  1. Tarvittaessa Avamar-tuki voi tarkistaa tämän Avamar-palvelinlokeista.

 

Cause

Tämä on normaalia toimintaa ja tapahtuu, kun Avamariin lisätään uusia tietoja varmuuskopioista.

 

Kun Avamarin säilytysastiat eli "raidat" jaetaan kahtia, sitä kutsutaan indeksijuovan halkaisuksi.

Tämä tapahtuu harvoissa tapauksissa harvoin ja vasta sen jälkeen, kun tietyt kapasiteettivälit on saavutettu solmun koon, määrän, version jne. mukaan. Tätä huoltotehtävää ei voi suorittaa kaasutoimituksen aikana.

 

Jos indeksiraita jaetaan, kun tiettyjä GC-toimintoja yritetään, GC sulkeutuu MSG_ERR_TRYAGAINLATER.

Jos indeksiraita on käynnissä GC ja sen on jaettava, se odottaa, kunnes GC-toiminnot on suoritettu.

 

Ruudukon indeksiraidoilla on taipumus jakautua suunnilleen samaan ajanjaksoon toistensa kanssa eri solmuissa. Joskus tämä voi kestää muutaman päivän.

 

Resolution

Avamar toimii suunnitellusti.
Kun indeksiraidan jako on valmis, roskien keräystä jatketaan.

 

Ongelman voi kiertää olemalla suorittamatta varmuuskopiointeja GC:n aikana.

 

Additional Information

  • Tätä käyttäytymistä ei tapahdu ruudukossa, joka on "vakaassa tilassa" (kapasiteetin käyttöaste on vakaa tai laskeva), koska kaikki raidat, joiden on oltava olemassa, ovat jo olemassa.
  • Tätä toimintaa ei tapahdu ruudukossa, joka on täyttynyt ja jonka kapasiteetti on sittemmin pienentynyt (ilman että sitä on laajennettu uusilla solmuilla). Tämä johtuu siitä, että kaikki raidat, jotka voidaan luoda ruudukkoon, ovat jo olemassa.
  • Tämä ongelma voi ilmetä, kun solmu on lisätty ja on olemassa lisäkapasiteettia raitojen jakamiseksi edelleen.
  • Ongelma saattaa toistua ajoittain, ja se ilmenee todennäköisemmin Avamar-verkoissa, joiden data kasvaa jatkuvasti tai joita on äskettäin laajennettu lisäsolmuilla.
  • Toiminta voi jatkua useita päiviä.

 

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000163002
Article Type: Solution
Last Modified: 23 Apr 2025
Version:  9
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.