Avamar: Error Code 22409: A Checkpoint Validation (hfscheck) is Overdue
Summary: Symptom Code 22409 (A checkpoint validation (hfscheck) is overdue) is reported due to an unresponsive avtar process.
Symptoms
This event may be generated even when a checkpoint validation (hfscheck) has been completing successfully every day.
The error can be seen in the logs (gsan.log, err.log), a dialhome, or in the Avamar UI:
22409 ERROR A checkpoint validation (hfscheck) of Avamar Server checkpoint data is overdue.
summary="A checkpoint validation (hfscheck) of Avamar Server checkpoint data is overdue."
type="ERROR"
code="22409"
Symptom: 22409, Desc: A checkpoint validation (hfscheck) of server checkpoint data is overdue
Cause
If the Management Console Server (MCS) avtar flush process does not end gracefully for any reason, it prevents future flushes from running as a new process cannot be started.
Resolution
1. Verify that there are no unavailable or problem avtar processes running on the utility node:
a. Log in to the Avamar Utility Node
b. Check for avtar processes:
ps - ef | grep avtar
c. Check the date and time of the process or processes.
If the process or processes are old, then this may be an indication of unresponsive avtar processes that must be killed:
kill -9 <PID>
(Where "<PID>" is the process ID or Id's collected from (b) above)
New avtar processes are likely associated with a current MCS flush, or replication.
2. Once any unresponsive avtar processes are cleared, monitor the grid for 48 hours to verify that the error does not recur.
If the issue is still not resolved, see Avamar: Symptom Code 22409 - A checkpoint validation (hfscheck) of server checkpoint data is overdue (Resolution Path)